It's one thing to teach a teckie about vbulletin, but can you teach a "dummy?"

Someone installed vbulletin for me. Now I need to upgrade from 3.7.2 patch Level 1 to...