Why should I get vBulletin 5.5.1? Nearly every vBulletin site I find is running 3.x or 4.x - even ones run by MH Sub I / Internet Brands. Why is this? It makes no sense that company-run/owned sites would...