I am currently running YABB 2.3 and want to purchase and convert my data to the vBulletin 4.0 Forum Classic. Should I upgrade my YABB board to the latest stable YABB version (YABB 2.5 AE) before trying...