I upgraded from 3.5.2 to 3.8.7 first, as suggested in the tutorial for upgrading.

After which, I upgraded from 3.8.7 to 5.0.5. After everything is said and over with, there's several issues...