I also had issues with this warning, but the warning seems to be gone after setting 'Disable AJAX Features' to 'Disable problematic AJAX Features' in the VBulletin Options in the admincp.