I wonder if problems like this should be fixed by the browser-maker (Mozilla) or by the bulletin-maker, it gets controversial right?

If it was fixed by the browser then there'd be a compatability...