This happened suddenly a couple of days ago on an old forum running (I think) 3.8.10 ...

Database error in vBulletin :

mysql_connect(): The mysql extension is deprecated and
...