Announcement

Collapse
No announcement yet.

PHP 5.2.17 to 5.3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • g00gl3r
    replied
    I've borrowed a shared hosting account that's running php 5.3 just to play around with this. I doubt I'll be upgrading my forums to it for a good 18 months if at all. It's a totally different product and I may as well look at other cheaper more stable and established options to be honest too.

    Leave a comment:


  • oldz442
    replied
    Originally posted by g00gl3r View Post
    What sort of things?
    Below is copied from a post I made a while ago after the issue was resolved. Still to this day, some of my custom PHP scripts do not work.

    -----------

    Followed the steps in the @scottej23 post @ link above (from the command line as I don’t have a ctl panel setup). Worked, but broke several things. ie. PEAR and MCRYPT. Found the below sites and commands which seemed to fix pear/mcrypt. I still have some other broken things though. ie. my custom PHP scripts are not working in some areas (getting division by zero among other errs).

    #########

    http://inderpreetsingh.com/2011/03/2...aditional-way/

    Install the older php-pear via yum install php-pear and than run the following commands:

    pear upgrade –force Console_Getopt
    pear upgrade –force pear
    pear upgrade-all

    #########

    http://www.excaliburtech.net/archives/222

    yum install php53-devel libmcrypt-devel gcc
    cd
    wget http://vault.centos.org/5.6/updates/...l5_6.1.src.rpm
    mkdir /usr/src/redhat
    rpm -i php53-5.3.3-1.el5_6.1.src.rpm
    cd /usr/src/redhat/SOURCES
    bunzip2 php-5.3.3.tar.bz2
    tar xf php-5.3.3.tar
    cd php-5.3.3/ext/mcrypt
    phpize
    aclocal
    ./configure
    make
    make install
    echo “extension=mcrypt.so” > /etc/php.d/mcrypt.ini
    service httpd restart

    Leave a comment:


  • g00gl3r
    replied
    Originally posted by beishe8 View Post
    With my host:


    I included it only in the vB5 folder's .htaccess file
    Seems the way we have cPanel setup, we can't do this.

    Leave a comment:


  • Hartmut
    replied
    You shouldnt have any problems.

    Leave a comment:


  • g00gl3r
    replied
    Thanks mate. Checking now.

    Leave a comment:


  • beishe8
    replied
    With my host:
    We currently have 5.3.10 (or higher) installed on all servers. A handler for
    PHP 5.3 is added to our shared and reseller servers for those who wish to
    utilize it. In order to utilize this handler, you will need to add the following
    code to your .htaccess file:

    # Use PHP 5.3
    AddType application/x-httpd-php53 .php
    I included it only in the vB5 folder's .htaccess file

    Leave a comment:


  • g00gl3r
    replied
    Yes mate basically.

    How would one go about doing that? My host is pretty flexible I'm sure they'd be able to do it if its possible.

    Leave a comment:


  • beishe8
    replied
    Originally posted by g00gl3r View Post
    Just bought a 5 connect to play around.

    Turns out I'm running PHP 5.2.17 so can't install it without upgrading.

    Do you think if I did, it'd break anything with VB4?
    So you want to have vB4 and vB5 on the same server and afraid to break something with PHP 5.3?
    You may be able to run vB4 with PHP 5.2 and vB5 with PHP 5.3 on the same server, it depends on your host.

    Leave a comment:


  • g00gl3r
    replied
    Originally posted by oldz442 View Post
    Not sure, but when I upgraded to 5.3, I broke several other non-forum related things. Fixed them all except one issue.
    What sort of things?

    Leave a comment:


  • Stancher
    replied
    Thanx

    Leave a comment:


  • oldz442
    replied
    Not sure, but when I upgraded to 5.3, I broke several other non-forum related things. Fixed them all except one issue.

    Leave a comment:


  • Zachery
    replied
    You'd be fine.

    Leave a comment:


  • g00gl3r
    started a topic PHP 5.2.17 to 5.3

    PHP 5.2.17 to 5.3

    Just bought a 5 connect to play around.

    Turns out I'm running PHP 5.2.17 so can't install it without upgrading.

    Do you think if I did, it'd break anything with VB4?

Related Topics

Collapse

Working...
X