Announcement

Collapse
No announcement yet.

Upgrade question

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Upgrade question

    I'm running 3.8 today If I upgrade to 5, can anyone tell me what the biggest problems Will be? Is it easy (like a normal 3.x) upgrade to install? Will I miss fex language translating as already done? Is there something you Know want work? Is there any discount for two licenses? And If you have something you Know its nice for me to know, please

  • #2
    If you are itching to upgrade, upgrade to 4.


    vB5 is unequivocally the best forum software, but not yet...

    Comment


    • #3
      Originally posted by lille L View Post
      I'm running 3.8 today If I upgrade to 5, can anyone tell me what the biggest problems Will be?
      That totally depends on your current installation, what addons/plugins you use, and if vB5 covers those features. The more customization you have, the more difficult (though not impossible) it will be to upgrade. That is the same with every software, I guess. It is not vB5-specific.

      Originally posted by lille L View Post
      Is it easy (like a normal 3.x) upgrade to install?
      Since you are planning to do a major upgrade, which is more than just upgrading within the same product line, I wouldn't expect it to be as easy as your previous upgrades. There might be conflicts with addons/plugins you are using, which would require your attention. However, as said before, this shouldn't be impossible. You should definetly do backups of your current installation and try to upgrade in a safe test environment!

      Originally posted by lille L View Post
      Will I miss fex language translating as already done? Is there something you Know want work?
      Sorry, I don't understand what you mean.

      Originally posted by lille L View Post
      Is there any discount for two licenses?
      I think bulk licensing starts at 3 licenses, but I might be wrong here. You should see the available options in your profile or during a purchase; if not, the Sales Support will help you ([email protected]).

      Originally posted by lille L View Post
      And If you have something you Know its nice for me to know, please
      Make sure to check, if vB5 meets your requirements/expectations, as it is still a fairly new product and some features from vB4 are missing. They might return over time, but if you are dependant on a certain feature, you might actually want to upgrade to vB4 first (and do another upgrade to vB5 later).

      I hope this helped you a little.

      Comment


      • lille L
        lille L commented
        Editing a comment
        Thank you so much for your answers ! It helped a lot !
        Im using norwegian language in my forum, and I understand that this language is not supported. But I believe I could download my language file in the 3.8 version, and upload it in the 5?

        I do not have a lot of plug in, mostly of my changes are template changes, and they will be possible to code back I believe.
        The few plugins that are most important is tapatalk and a few products, which isn't important.

        But, if I upgrade to 5, and you say there is something from 4 thats missing. What will I miss? :-)
        Since I never had the forum on version 4? Is it likewise what I choose then?

    • #4
      Originally posted by beishe8 View Post
      If you are itching to upgrade, upgrade to 4.
      Why to 4, and not 5 ?

      Comment


      • #5
        Originally posted by lille L
        Im using norwegian language in my forum, and I understand that this language is not supported. But I believe I could download my language file in the 3.8 version, and upload it in the 5?
        The vB5 language file has a lot more phrases than the vB3 file. I think it will not work to simply copy/paste the content of the vB3 file into the vB5 file. If you want to have a fully translated vB5, you should consider to translate the latest language file.

        Originally posted by lille L
        But, if I upgrade to 5, and you say there is something from 4 thats missing. What will I miss? :-)
        I am not saying that you will miss it. I am saying that vB5 does not have all of the features of vB4 yet, for example the calendar or the post indicator (which I personally miss a lot). That doesn't mean you can't use vB5, since it depends on what you actually need.

        To put it in a general way: vB4 is the older, but more solid product, since it is already in development for quite a few years. Also there are a lot of addons/plugins and themes available for that version, check out www.vbulletin.org – the official site for modifications and stuff. (This is why some people prefer vB4 over vB5 at this point.) vB5 however is the more recent release, supports newer technology (latest browsers, PHP etc.), will longer be supported...

        By the way: If you buy a vB5 license (which is the only license available), this also gives you access to vB4 (and vB3), so you can test all of those versions in the first place, and then decide based on what version you liked most.

        Comment


        • #6
          Originally posted by TLMD View Post
          The vB5 language file has a lot more phrases than the vB3 file. I think it will not work to simply copy/paste the content of the vB3 file into the vB5 file. If you want to have a fully translated vB5, you should consider to translate the latest language file.


          I am not saying that you will miss it. I am saying that vB5 does not have all of the features of vB4 yet, for example the calendar or the post indicator (which I personally miss a lot). That doesn't mean you can't use vB5, since it depends on what you actually need.

          To put it in a general way: vB4 is the older, but more solid product, since it is already in development for quite a few years. Also there are a lot of addons/plugins and themes available for that version (check out www.vbulletin.org – the official site for modifications and stuff). vB5 however is the more recent release, supports newer technology (latest browsers, PHP etc.), will longer be supported... (This is why some people prefer vB4 over vB5 at this point.)

          By the way: If you buy a vB5 license (which is the only license available), this also gives you access to vB4 (and vB3), so you can test all of those versions in the first place, and then decide based on what version you liked most.

          Thank you so much for your good answers ! Yes I bought the v5 license upgrade. Its nice to know it works on all versions
          My style want work on the v4, that why I thought of v5. Since I already have to change my style and make changes :-)
          Since I haven't tried v4, and my users hasn't either, I was thinking that go to v5 would be the best thing to do :-) Since we all have to adjust the changes

          Have you used version 3? What are your personal opinion (I see that you speak warmly for v4 ) if you should upgrade?
          If you don't take all the mods and adjustments from the .org site in consideration?

          Sorry for all my stupid questions :/

          Comment


          • #7
            Originally posted by lille L View Post
            Since I haven't tried v4, and my users hasn't either, I was thinking that go to v5 would be the best thing to do :-) Since we all have to adjust the changes
            True words...

            Originally posted by lille L View Post
            Have you used version 3?
            No, not really, since I am from the "post-vB3 era". However, I have used vB3 as a user and as a moderator on some forums in the past, so I have some basic experience with that version.

            Originally posted by lille L View Post
            What are your personal opinion (I see that you speak warmly for v4 ) if you should upgrade?
            If you don't take all the mods and adjustments from the .org site in consideration?
            Personally I'd recommend you to do a test installation of both vB4 and vB5 (localhost or something) and then, since you are excluding all the addon stuff for now, have a look at the vanilla versions. This allowes you to get an unbiased opinion about both versions. If you find out that vB5 covers all your needs, I'd definetly go with vB5, since this is the latest version and it is actively being developed. vB 5.1.0 is the next (bigger) upgrade, which will be released very soon, and it adresses a lot of the issues of the current vB 5.0.5.

            Comment


            • #8
              Originally posted by TLMD View Post
              True words...


              No, not really, since I am from the "post-vB3 era". However, I have used vB3 as a user and as a moderator on some forums in the past, so I have some basic experience with that version.


              Personally I'd recommend you to do a test installation of both vB4 and vB5 (localhost or something) and then, since you are excluding all the addon stuff for now, have a look at the vanilla versions. This allowes you to get an unbiased opinion about both versions. If you find out that vB5 covers all your needs, I'd definetly go with vB5, since this is the latest version and it is actively being developed. vB 5.1.0 is the next (bigger) upgrade, which will be released very soon, and it adresses a lot of the issues of the current vB 5.0.5.
              Thank you once more ! You are the best !
              I will install v5, and if its covers my needs - I think I'll keep it.
              I'm afraid if I install both, I will get lost in the choices

              If there is a lot of thing I'm missing, or think should be there - I will install v4 also :-)

              Comment

              Related Topics

              Collapse

              Working...
              X