Announcement

Collapse
No announcement yet.

How can I renew my licence for 3.8.4?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Originally posted by feldon23 View Post
    The only decent thing to do here is to provide a price, say $50, that 'catches us up' on 3.8.x and provides download access to all future versions of 3.8.x.

    vBulletin got all the money they're going to get out of vB4 for a while, and all that's left is angry 3.x customers who refuse to pay $185 for security updates.

    If vBulletin offered a $50 price for lifetime downloads of 3.8.x, they would get quite a bit of revenue here. These are customers who do not want vB4 and are looking at ditching your software. Offering this option would be a net gain with very little downside.7

    You'd also be leaving the door open to convincing us that vBulletin 4 can be salvaged, instead of us just turning our back on vBulletin forever and never looking back.
    I agree that there needs to be some sort of "Maintenance License" purchase option for those of us who are sticking with 3.x, especially given that IB is still releasing patches for the 3.x series.

    I agree also with your assessment that many of us have been looking to step away from vBulletin altogether following the vB4 release, and some sort of intermediate option to keep us linked with vB3 would be all we need to keep our minds open to what vB4 and the future have in store for us. Not doing so only forces our hand earlier rather than later.

    Comment


    • #32
      Originally posted by Kaelon View Post
      I agree that there needs to be some sort of "Maintenance License" purchase option for those of us who are sticking with 3.x, especially given that IB is still releasing patches for the 3.x series.

      I agree also with your assessment that many of us have been looking to step away from vBulletin altogether following the vB4 release, and some sort of intermediate option to keep us linked with vB3 would be all we need to keep our minds open to what vB4 and the future have in store for us. Not doing so only forces our hand earlier rather than later.
      I doubt that will happen, if not only for the reason that 3.x will be EOL soon anyway.

      Comment


      • #33
        Originally posted by Floris View Post
        I doubt that will happen, if not only for the reason that 3.x will be EOL soon anyway.
        Regarding EOL... at least 3.x has/had a life. 4.x is still waiting to be reborn... right now we're dealing with a monstrosity.

        Comment


        • #34
          It seems that the vbulletin team members disappeared from this thread, i am too on the same boat with a worthless 3.8.x expired license. I wish they would reconsider their pricing structure and value their loyal customers
          WebDevPlace - Your connection with web developers
          Ayuda de vBulletin en Espaņol

          Comment


          • #35
            Originally posted by Floris View Post
            Users who PAID for vBulletin 4: vBulletin 4 License Type License Agreement. - All upgrades are free, maintenance releases, upgrades, and security patches. Until version 5 - you have to pay again.
            Users who DID NOT PAY for vBulletin 4 (despite getting a "free" upgrade): vBulletin 3 License Type License Agreement. - All upgrades for your 3.x and "Free" 4.x license are free and available until you hit the expiry date. Maintenance releases are free and downloadable until you expiry date. Security patches from what Zachery says, will be free for 3.x even if you hit your expiry date. With a 3.x license type LA if your license expired and you had a free upgrade to version 4, if then version 4.1 or 4.9 gets released, or a maintenance release: You have to pay the full upgrade price to a version 4 license type; despite that the upgrade was "free".
            Thanks for your detailed reply Floris. The part that I've highlighted is the part that interests me the most and something I'd like vBulletin staff to clarify. I still have a few boards running 3.8.4 and security is my only concern. They will never be upgraded to vB4 but I'd prefer at this time to keep them running on a vBulletin platform. 3.8.x may be heading towards EoL but it still provides a robust platform from which to run a forum and the members have indicated quite strongly that they are happy to have them maintained for sometime to come.


            Originally posted by mariohn View Post
            It seems that the vbulletin team members disappeared from this thread, i am too on the same boat with a worthless 3.8.x expired license. I wish they would reconsider their pricing structure and value their loyal customers
            Although I don't like to generalise, I've found that American based companies seem to value short term gain over customer loyalty. It's certainly been the case with the companies I've dealt with in recent times and Internet Brands seems no different in that respect. What does surprise me a little is the lack of customer care shown in these forums. American based companies usual excel in that area but it doesn't seem to be the case here. Perhaps these forums are not seen as a priority but I would have thought they were the first port of call for many prospective customers.
            .

            Comment


            • #36
              And here we are, and the only way to be secure on 3.7 and 3.8 with the new vulnerability is to BUY for $185 a vBulletin 4 license.

              Comment


              • #37
                It certainly looks that way at the moment. Will there be a patch released for those running 3.8.4 to address the latest security issue or not?
                .

                Comment


                • #38
                  Doesn't look like there's going to be an official patch.
                  Planning to continue using VB 3.8 post EOL? Then join the VB 3.8 Forever group and vB3Forever.org!

                  Comment


                  • #39
                    Originally posted by mlx View Post
                    Doesn't look like there's going to be an official patch.
                    There are always unofficial ones.

                    Comment


                    • #40
                      Originally posted by feldon23 View Post
                      And here we are, and the only way to be secure on 3.7 and 3.8 with the new vulnerability is to BUY for $185 a vBulletin 4 license.
                      I'm with you mate on this. I do feel somewhat disowned by VB. I also don't want to move to VB4 but I do have an owned licence for 3.8.4.

                      The current structure says that I have to put up with bugs and security fixes that really should not of been in the product anyway.

                      so because I can't afford vb4 licence I have to provide my users with a forum that has bugs and/or security flaws.

                      does not sound right to me. It's like finding flaws or leaving them in there because it could generate sales for VB4.

                      Certainly not good for us users that want to stay with 3.

                      Comment


                      • #41
                        I also was led to believe that security patches would be provided, its not as though we 3.8.4 users want new features, we just want to be safe from the flaw in VBulletin's own code, and they want us to pay ?
                        I assume this is why its taking them so long to answer tickets, many people are likely complaining about their awful paying customer service.

                        Comment


                        • #42
                          Originally posted by Zachery View Post
                          Sorry, thats mostly incorrect.

                          When an owned license expires we still provide access to patches for the current version, as it has always been.

                          You can still download any version of vbulletin you had access to.
                          You can still run the software.

                          I'd hardly call that worthless.
                          I'd call it completely worthless unless you are happy to run an insecure forum.
                          .

                          Comment

                          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                          Working...
                          X