Announcement

Collapse
No announcement yet.

Pre-purchase MYSQL and PHP Config

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Pre-purchase MYSQL and PHP Config

    After perusing some of the forums, I was thinking I'd try and get mysql and php running with my webserver before I got a headache trying to install this software because I wasn't prepared with other functions. I got it working so with a test.php file

    <?php
    phpinfo();
    ?>

    I got what I was looking for.

    I was then screwing around with apache to make sure I could setup an .htaccess protected admin directory. I restarted httpd, now when I try and look at test.php, my browser tried to download the file. I no longer am able to get anything other than the download dialog. ACK! What did I do. I'd really like to get this worked out before I purchase or try the lite version. Any help would be greatly appreciated!

    Thanks!

    htimst

  • #2
    Chances are you removed the lines that make PHP work with Apache. Unless you really did some deleting, the comments that explain how to do it should still be there. Just search for php in httpd.conf.

    http://www.php.net/manual/en/faq.installation.php

    Comment


    • #3
      **groan**

      I really only added a <Directory></Directory> convention. I can't see the problem. I made no modifications to the php portions of the httpd.conf file. I know it HAS to be Apache as it's not parsing the php files at all anymore...I want to scream!

      Comment


      • #4
        Hmm...is the directory you are trying to use .htaccess with the same directory that your test.php file is in by any chance?

        Comment


        • #5
          Just to check;

          Do you have the line in bold entered in your http.conf file;

          Code:
          <IfModule mod_dir.c>
                   DirectoryIndex index.html
              DirectoryIndex index.php
                   DirectoryIndex index.htm
          </IfModule>
          Code:
          ScriptAlias /php/ "c:/php/"
          Code:
          AddType application/x-httpd-php .php
          Code:
          Action application/x-httpd-php "/php/php.exe"
          All in http.conf
          Last edited by Kaizen; Mon 26 Nov '01, 5:54am.
          Email: [email protected]
          Site: Under Construction

          Comment


          • #6
            Got it.

            Thanks for your help. I went searching for the libphp4.so module because, though it was there, I was getting rid of the rpm installs of mysql and php and installed from the source instead. I must have rpm -e instead of a query and the php modules were deleted. Thanks for all that helped, I can test this baby out now.

            Cheers!

            Comment


            • #7
              Originally posted by Kaizen

              Code:
              ScriptAlias /php/ "c:/php/"
              f
              you've been running apache on WindBlows

              Comment


              • #8
                Originally posted by Kazan


                you've been running apache on WindBlows
                I have.

                Correction: MINDBLOWS !

                It is a pain in the arse and thats why i'm getting a nice Redhat server.
                Email: [email protected]
                Site: Under Construction

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X