Announcement

Collapse
No announcement yet.

Are Amazon Affiliate product links not allowed?

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Are Amazon Affiliate product links not allowed?

    I signed up for the demo in order to test out whether I'd be allowed to place Amazon affiliate product links in my posts. Result? Complete failure. Doesn't work.

    What's the problem? Is there some weird trick to this?? Does vB perhaps have a policy against allowing Amazon product links? Is it just a problem with their new 4.0 version?

    This is a deal-breaker for me. If vB won't allow me to post my affiliate product links, then I won't use vB.

    For reference, here are the two affiliate links I tried to place in my post:

    <iframe src="http://rcm.amazon.com/e/cm?t=boin07b-20&o=1&p=8&l=as1&asins=0887306667&fc1=000000&IS2=1&lt1=_blank&m=amazon&lc1=0000FF&bc1=0000 00&bg1=FFFFFF&f=ifr" style="width:120px;height:240px;" scrolling="no" marginwidth="0" marginheight="0" frameborder="0"></iframe>

    <a href="http://www.amazon.com/gp/product/0887306667?ie=UTF8&tag=boin07b-20&linkCode=as2&camp=1789&creative=9325&creativeASIN=0887306667"><img border="0" src="51A2W0sRp9L._SL160_.jpg"></a><img src="http://www.assoc-amazon.com/e/ir?t=boin07b-20&l=as2&o=1&a=0887306667" width="1" height="1" border="0" alt="" style="border:none !important; margin:0px !important;" />

  • #2
    Works fine for me: Amazon Affiliate Link (reposted from above)

    The problem with what you're posting above is that it's HTML. vBulletin.com doesn't allow users to post HTML for security reasons. However, if you run vB you can always enable HTML on your own forum. That said, there are other ways to display your affiliate links, like custom BB-Codes, or just the plain old URL like I did above.
    - the makers of VaultWiki

    Comment


    • #3
      The code you are trying to paste is HTML, it is a security breach to allow HTML posting, you need to convert the code to BBcode for it to be parsed correctly. That is the default behavior on any forum software
      Iframe can not be used unless you create a custom BBcode but the second one is easily convertible to BBcode

      Comment


      • #4
        thincom2000,

        I'm wanting the picture of the book to show up in the post as the link. So people see the image and click on it to go to the appropriate Amazon page.

        Comment


        • #5
          Originally posted by yemgi View Post
          The code you are trying to paste is HTML, it is a security breach to allow HTML posting, you need to convert the code to BBcode for it to be parsed correctly. That is the default behavior on any forum software
          Iframe can not be used unless you create a custom BBcode but the second one is easily convertible to BBcode
          It's still not working. Here's what I'm doing:

          1) generating the codes (see above) at Amazon

          2) going to http://www.odditysoftware.com/page-webtools15.htm and converting html to bbcode

          3) copying the bbcode and pasting it into a reply box

          4) failure. no picture. no link. just the code sitting there as text.

          Comment


          • #6
            Originally posted by Bubstubbler View Post
            It's still not working. Here's what I'm doing:
            Try this instead....

            [url={YOUR AMAZON AFFILIATE URL LINK}][img]{PATH TO YOUR IMAGE}[/img][/url]


            [URL="http://coolscifi.com"]Cool Sci-Fi[/URL="http://coolscifi.com"] | [URL="http://awalkerbit.me"]Walking Dead[/URL="awalkerbit.me"]

            Comment


            • #7
              The odditysoftware link you posted doesn't generate valid BB-Code. Looks like there's some bugs with that tool, unfortunately. If you use KW802's suggestion, it will work correctly on any board where URL and IMG codes are permitted.
              - the makers of VaultWiki

              Comment


              • #8
                KW802's suggestion did not work.

                Please somebody tell me step-by-step how to get this to work. Please test your suggestion yourself using the code provided in the original post before posting it, to ensure that your suggestion works.

                Comment


                • #9


                  try this

                  Comment


                  • #10
                    Originally posted by Bubstubbler View Post
                    KW802's suggestion did not work.

                    Please somebody tell me step-by-step how to get this to work. Please test your suggestion yourself using the code provided in the original post before posting it, to ensure that your suggestion works.
                    Sure looks like it's working.

                    Originally posted by Bubstubbler View Post


                    try this
                    [URL="http://coolscifi.com"]Cool Sci-Fi[/URL="http://coolscifi.com"] | [URL="http://awalkerbit.me"]Walking Dead[/URL="awalkerbit.me"]

                    Comment


                    • #11
                      Yeah, the img code Amazon was generating was faulty. So I snagged the img location from the product's properties, instead, and inserted it into your formula.

                      It got the image to show up (as you can see), but there is a worrisome aspect: the image url generated by Amazon had my affiliate tracking code in it, but the img url I get by right-clicking on the pic doesn't.

                      To re-phrase: originally, both the href and img urls had my affiliate code; now only the href does. Is this good enough? If someone clicks on the link and buys the book, will I get paid?

                      Comment


                      • #12
                        If your affiliate code is 0887306667 you will... That's in the Amazon URL when I click your image.

                        Comment


                        • #13
                          Originally posted by Bubstubbler View Post
                          Yeah, the img code Amazon was generating was faulty. So I snagged the img location from the product's properties, instead, and inserted it into your formula.

                          It got the image to show up (as you can see), but there is a worrisome aspect: the image url generated by Amazon had my affiliate tracking code in it, but the img url I get by right-clicking on the pic doesn't.

                          To re-phrase: originally, both the href and img urls had my affiliate code; now only the href does. Is this good enough? If someone clicks on the link and buys the book, will I get paid?
                          The important part is the the value used in the URL tag, not the IMG tag. Just make sure that your URL tag value is the one that contains your Amazon affiliate code and you'll be good to go. When you use the IMG tag inside of the URL tag, when your visitors click on the picture in the IMG, then it is the URL tag that will decide where they go.

                          So in short... make sure your URL tags have your affiliate codes in them.
                          [URL="http://coolscifi.com"]Cool Sci-Fi[/URL="http://coolscifi.com"] | [URL="http://awalkerbit.me"]Walking Dead[/URL="awalkerbit.me"]

                          Comment


                          • #14
                            I am having this exact same problem, but for some reason the responses here are just not registering in my head.

                            Can someone please explain it to me as if I had the intelligence and attention span of a two-year-old? Please - I am actually quite serious.

                            Comment


                            • #15
                              Originally posted by Dave234 View Post
                              I am having this exact same problem, but for some reason the responses here are just not registering in my head.

                              Can someone please explain it to me as if I had the intelligence and attention span of a two-year-old? Please - I am actually quite serious.
                              Hi Fave

                              This thread is three years old.
                              Please could you start your own thread in the relevant support forum for your version, and we'll try to help.
                              MARK.B | vBULLETIN SUPPORT

                              TalkNewsUK - My vBulletin 5.6.3 Demo
                              AdminAmmo - My Cloud Demo

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X