Announcement

Collapse
No announcement yet.

I am running my forums on 3.8.2 can I upgrade to 4.x?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • I am running my forums on 3.8.2 can I upgrade to 4.x?

    I am currently running my forums on 3.x

    Can I purchase the vb4 now? and simply run install>upgrade ? or Do I need to use impex and stuff.

    Let me know.

    Thanks.

  • #2
    Good. Yes. Yes. No. Okay. You're welcome. Read FAQ.
    "The lurking suspicion that something could be simplified is the world's richest source of rewarding challenges"
    - Edsger Dijkstra

    Comment


    • #3
      Originally posted by renep View Post
      Good. Yes. Yes. No. Okay. You're welcome. Read FAQ.
      Not very helpful, but allow me to go into a bit more detail.

      You may purchase vB 4 in the presale now. As with all cases, you'll gain access to the beta soon (if you buy it), sometime this month.
      If is better is you have fewer styles and modifications installed. vB 3.x Styles will not work with vB 4, and modifications which output to the front end, will require work (by modification author) to update to new platform.

      It is up to you whether you use ImpEx or not. If your database is cluttered with things you don't need, and you don't mind losing all of your modication and settings, which use the database, then by all means, use ImpEx.
      Shamil Nunhuck, - Radon Systems Ltd.
      VPS + Dedicated Server Hosting and Management
      vBulletin Hosting and Services
      Server / Website Consultation

      Comment


      • #4
        From all I have read, you can not use IMPEX to upgrade.
        ...steven
        www.318ti.org (vB3.8) | www.nccbmwcca.org (vB4.2)
        bmwcca.org/forum | m135i.net
        "I tried to clean this up but this thread is beyond redemption." - Steve Machol

        Comment


        • #5
          Originally posted by 1996 328ti View Post
          From all I have read, you can not use IMPEX to upgrade.
          ImpEx is not a recommended upgrade path, however, it can be used to merge two boards together.

          Comment


          • #6
            If you want to start a new database you can use impex to bring your members and posts over and install vb4 as a brand new install and bring your members across with impex.

            Comment


            • #7
              Originally posted by sportsfi View Post
              If you want to start a new database you can use impex to bring your members and posts over and install vb4 as a brand new install and bring your members across with impex.
              Generally, that is a bad choice, because you will break any existing links to your forums. All unique keys are essentially renumbered when ImpEx is used.

              Comment


              • #8
                well i have 3.8.4 installed and i do want to try this v4 suite but don't want to lose my registered members and posts and topics ..the vbmods and skins i dont care if i lose them ..is there any working way for this ??

                Comment


                • #9
                  dont know why this upgrade would be any different to any other upgrade?

                  Comment


                  • #10
                    I have over 3 million posts on my forums, but style does not matter much, I can go with the default style of vb4, I am not using any special plugins/hacks other than "hide hack". So I am still confused if I should go with impex or there will be a normal upgrade option when I run install. What should ppl who have big forums do in this case.

                    Thankyou very much for your reply.

                    Originally posted by deuterium View Post
                    Not very helpful, but allow me to go into a bit more detail.

                    You may purchase vB 4 in the presale now. As with all cases, you'll gain access to the beta soon (if you buy it), sometime this month.
                    If is better is you have fewer styles and modifications installed. vB 3.x Styles will not work with vB 4, and modifications which output to the front end, will require work (by modification author) to update to new platform.

                    It is up to you whether you use ImpEx or not. If your database is cluttered with things you don't need, and you don't mind losing all of your modication and settings, which use the database, then by all means, use ImpEx.

                    Comment


                    • #11
                      You will be able to run an upgrade just like with any other version of vBulletin. The upgrade process is the same. Just make sure you disable existing modifications before upgrading.

                      Comment


                      • #12
                        Originally posted by Queen View Post
                        I have over 3 million posts on my forums, but style does not matter much, I can go with the default style of vb4, I am not using any special plugins/hacks other than "hide hack". So I am still confused if I should go with impex or there will be a normal upgrade option when I run install. What should ppl who have big forums do in this case.

                        Thankyou very much for your reply.
                        I wouldn't use Impex, at all. Do an upgrade like you normally would - make backups, etc, and test it before upgrading the production/live site.
                        Regards,
                        Eric Sizemore


                        My modifications

                        Comment


                        • #13
                          What about URLs of existing posts? How is that working? Are we talking about dropping being indexed and then being reindexed? Multiple URLs for one page?
                          My law forum, lawyers and legal help site

                          Comment


                          • #14
                            Assuming you upgrade instead of using Impex the existing URLs will work fine.
                            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                            Change CKEditor Colors to Match Style (for 4.1.4 and above)

                            Steve Machol Photography


                            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                            Comment


                            • #15
                              Originally posted by Steve Machol View Post
                              Assuming you upgrade instead of using Impex the existing URLs will work fine.
                              Thanks - but what does this mean? The URLs are different in v4. How is the transition managed? What should we expect as far as search engines, etc.
                              My law forum, lawyers and legal help site

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X