Announcement

Collapse
No announcement yet.

system requirements for vBulletin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • system requirements for vBulletin

    It is recommended to use PHP 5.2.6, or later and MySQL 5.0.19 or later.
    My PHP version is 5.1.6

    MySQL is 5.0.22

    I've already prepurchased, can I still run it?

    I own a VPS and have updated all the necessary components.

  • #2
    You will need to upgrade the PHP software installed. vBulletin 4 will require PHP 5.2 or greater.

    Comment


    • #3
      Bad news I was hoping not to hear. I have done the necessary upgrades to my VPS and PHP hasn't upgraded.

      Comment


      • #4
        will it stil work with my current setup? 5.2.6 is only 'recommended'

        Comment


        • #5
          5.2.6 is recommended, but a baseline of any version of PHP 5.2 is required.

          Comment


          • #6
            I hope everyone is paying attention to this... I went looking for hosting services a while back (keeping the vB4 requirements in mind) and I was surprised how many hosts did NOT have the necessary versions available.

            Comment


            • #7
              That's going to cause issues with my server as Centos 5 does not use 5.2x. They back port just about everything though so should be interesting to see if vb4 will run on a Centos 5 server.

              Comment


              • #8
                I've been in touch with my hosting company who provide the VPS and all they can tell me is that a new VPS will have PHP 5 and MySQL 5. Plesk apparently controls the actual version. I have updated my plesk however the PHP version has not upgraded.

                Comment


                • #9
                  This issue has been the cause of some stress and anxiety! I'm now faced with a dillema. To end my forum which I've built up for the last 4 years. Or find another host, which seems difficult to do as none specify which version of PHP5 they include!

                  Is there an ETA for the forum and suite?

                  Comment


                  • #10
                    You have a vps yoijob? Why can't you just compile from source?

                    Comment


                    • #11
                      No hosts that tell you what version of PHP they are running? You must be kidding. If it's not on their homepage, contact them and ask. If they don't tell you, that's all you need to know: find another one who does. Frankly, I think it's not a vB problem that there are lazy hosts that do not keep the server software up to date. vB can't be expected to run forever on outdated versions, causing unnecessary overhead for everyone who does run fairly up to date software on his server.

                      Comment


                      • #12
                        If you are going to be running the Suite, you will definitely need to upgrade your php. (Spoken from experience.)

                        Please don't PM or VM me for support - I only help out in the threads.
                        vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                        Want help modifying your vbulletin forum? Head on over to vbulletin.org
                        If I post CSS and you don't know where it goes, throw it into the additional.css template.

                        W3Schools <- awesome site for html/css help

                        Comment


                        • #13
                          Originally posted by Lynne View Post
                          If you are going to be running the Suite, you will definitely need to upgrade your php. (Spoken from experience.)
                          I was trying to install vb4 in my centos 5 home server and this is what i get..

                          vBulletin 4.0.0 Beta 5 requires PHP version 5.1.2 or greater. Your PHP is version 5.1.6, please ask your host to upgrade.
                          isn't 5.1.6 > 5.1.2 equal true ? then,,
                          the server doesn't have access to the internet to install PHP v5.2.x and it doesn't have a cd rom either.. (i do have a USB stick with 2 Gb of space)

                          i will google this...

                          i am ..

                          Comment


                          • #14
                            Its 5.2.0 or newer. Not sure whats up with that. The offical requirements have been posted.

                            Comment


                            • #15
                              Originally posted by Zachery View Post
                              Its 5.2.0 or newer. Not sure whats up with that. The offical requirements have been posted.
                              yes.., you're right, i dont know whats up with the error, i've managed to update PHP see below and vbulletin is working now

                              Minimum:
                              PHP: 5.2.0
                              MySQL: 4.1.0

                              Recommended
                              PHP: 5.2.6 or newer
                              MySQL: 5.0.19 or newer

                              > php -v
                              PHP 5.2.6 (cli) (built: Sep 15 2008 20:42:05)
                              Copyright (c) 1997-2008 The PHP Group
                              Zend Engine v2.2.0, Copyright (c) 1998-2008 Zend Technologies
                              i should of check the requirements first.

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X