Announcement

Collapse
No announcement yet.

PHP Requirements

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • PHP Requirements

    What are the requirements for PHP on my server? My server has PHP 5.1.6. Is this current enough for VB 4.0??

  • #2
    Originally posted by joe1989 View Post
    What are the requirements for PHP on my server? My server has PHP 5.1.6. Is this current enough for VB 4.0??
    Read below... My mistake... The latest PHP is 5.3 and 5.2.11 -- You are not too terribly far behind. I think I saw that PHP 5 was a minimum for VB4, while PHP 4.3.3 was a minimum for VB3.8.

    EDIT: Whoops!!! PHP 5.2 is needed, apparently.
    Originally posted by FAQ
    Minimum Requirements: vBulletin is designed to run on every server that has PHP 5.2 or greater and MySQL 4.0.16 or greater installed.
    It is recommended to use PHP 5.2.6, or later and MySQL 5.0.19 or later.
    To be updated...

    Comment


    • #3
      Originally posted by joe1989 View Post
      What are the requirements for PHP on my server? My server has PHP 5.1.6. Is this current enough for VB 4.0??
      Straight from FAQ page What are the system requirements for vBulletin?

      What are the system requirements for vBulletin?

      Minimum Requirements: vBulletin is designed to run on every server that has PHP 5.2 or greater and MySQL 4.0.16 or greater installed.

      It is recommended to use PHP 5.2.6, or later and MySQL 5.0.19 or later.

      The software has been successfully installed on several different flavours of UNIX, as well as Windows™ 98/NT/2000/XP, and the Mac

      Note: We recommend you contact your hosting provider to verify that they have the correct versions of PHP and MySQL installed. If you administrate your own server, PHP and MySQL are available for free download from PHP.net and MySQL.com.
      :: Always Back Up Forum Database + Attachments BEFORE upgrading !
      :: Nginx SPDY SSL - World Flags Demo [video results]
      :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

      Comment


      • #4
        I'm curious if this is also the case for vBulletin 3.8.x? I want to upgrade my installations of php and mysql to the current stable versions. Will vb 3.8.x be OK with this?

        Comment


        • #5
          Originally posted by Kirkus View Post
          I'm curious if this is also the case for vBulletin 3.8.x? I want to upgrade my installations of php and mysql to the current stable versions. Will vb 3.8.x be OK with this?
          VB 3.8 requires at least PHP4.3.3 and MySQL 4.0.16.
          To be updated...

          Comment


          • #6
            Originally posted by Kirkus View Post
            I'm curious if this is also the case for vBulletin 3.8.x? I want to upgrade my installations of php and mysql to the current stable versions. Will vb 3.8.x be OK with this?
            vBulletin 3 will run fine on the latest stable versions of PHP/MySQL.

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X