Announcement

Collapse
No announcement yet.

Few important questions before I use vB...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Few important questions before I use vB...

    Hi All,
    When I run the vBulletin compatibility test on my server, I got these 2 points failed...

    I know these are optional for vBulletin installation. But do you advise me to get them done on my server ?

    1) magic_quotes_gpc should be off for optimal performance, ask your host to change this in php.ini

    2) GD functions are used to produce images, this includes features such as thumbnails and image verification on registration

    Also my server meets the PHP and MySQL minimum requirements for installation of vBulletin.

    But it does NOT meet the recommended requirements of
    PHP 4.4.2 or 5.1.2 or later and MySQL 5.0.19 or later.

    Do you advise me to update my server to have these latest versions of PHP 5.1.2 and MySQL 5.0.19 ? Does it have any specific advantage in terms of performance or something else ?




  • #2
    #1 is not important.

    And while vB will run without #2, you will not be able to use image verification, thumbnails and resize pictures. Just ask your host to recompile PHP with GD and Freetype2 support.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      I intend to run vBulletin 3.7

      you will notice if you intend on running 3.7.0
      Yes, I intend to run vBulletin 3.7
      It's my own dedicated server. So there should not be any problem if I tell them to upgrade PHP & mySQL.

      The only problem is I have some other sites (with some other CMS) on same server.
      So will there be any problems for any of those sites if I upgrade PHP and MySQL to latest versions ?
      (I assume there should NOT be any, as I am UPGRADING, but asking for confirmation...)

      Comment


      • #4
        In all honesty, you should really be asking the support for the other applications. Anyway, in theory there shouldn't be any problem, but that doesn't mean there wont.
        http://data.collectiveirc.net/status/user/Jobe.png

        Comment


        • #5
          what's Freetype2

          Just ask your host to recompile PHP with GD and Freetype2 support.
          Sorry for my ignorance, but what's Freetype2 ?

          Comment


          • #6
            Freetype2: http://freetype.sourceforge.net/index2.html
            Best Regards,
            Andy Huang

            Comment


            • #7
              Thank You

              Do I need to install on my server the latest version - FreeType 2.3.5

              Installing this is necessary along with GD ??

              I am asking this because I don't remember seeing any mention of Free Type in server requirements test wizard of vBulletin.

              Comment


              • #8
                Yes, it should be installed along with GD.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Freetype is a dependency of GD if used with truetype support.

                  Comment


                  • #10
                    GD Installed

                    I got GD and TTF Installed on my server.

                    Thanks a lot to all those replied...

                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X