Announcement

Collapse
No announcement yet.

Converting Mybb 1.2.10 to vB

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts
    Revolution Yes
    Member

  • Revolution Yes
    replied
    Originally posted by Steve Machol View Post
    Basically all you need to do is rename the old directory to something else, then rename the vB directory to 'forums'. Be sure to set the correct forum URL here:

    Admin CP -> vBulletin Options -> Site Name / URL / Contact Details -> Forum URL

    And in the Members Area under 'License Options':

    http://www.vbulletin.com/members/
    Thankyou for all of your help Steve, my import from Mybb to vBulletin seems to have worked out great!

    Originally posted by Audentio View Post
    Just to perhaps help assure you in some small way, I used Impex to move my board from mybb to vb 3.6.0 awhile back. Flawless and worth it a hundred-fold. I love MyBB, they are a great community and offer one of the best software there is, but my personal opinion is that mybb just doesn't offer the support, mods, or features (yet) that I need for my specific types of communities.[/rant]
    Thanks for the reassurance Audentio I too have alot of time for Mybb and their product, but ultimately the problems I was having made me make the inevitable move to vB that bit earlier.

    Leave a comment:

  • Audentio
    New Member

  • Audentio
    replied
    Just to perhaps help assure you in some small way, I used Impex to move my board from mybb to vb 3.6.0 awhile back. Flawless and worth it a hundred-fold. I love MyBB, they are a great community and offer one of the best software there is, but my personal opinion is that mybb just doesn't offer the support, mods, or features (yet) that I need for my specific types of communities.[/rant]

    Leave a comment:

  • Steve Machol
    Former Customer Support Manager

  • Steve Machol
    replied
    Basically all you need to do is rename the old directory to something else, then rename the vB directory to 'forums'. Be sure to set the correct forum URL here:

    Admin CP -> vBulletin Options -> Site Name / URL / Contact Details -> Forum URL

    And in the Members Area under 'License Options':

    http://www.vbulletin.com/members/

    Leave a comment:

  • Revolution Yes
    Member

  • Revolution Yes
    replied
    Thankyou once again Steve, that was indeed the problem.

    Can I just ask something else:

    If my current forum is at (for example) www.abc123.com/forums and my import is at www.abc123.com/forum (NOT forums), how do I move it to the original /forums URL without breaking the import and so that my members do not have to learn a new URL?

    I know you covered this above, but can I clarify whether it really is as simple as changing the vBulletin directory to /forums and the Mybb directory to something else?

    Thanks for all of your time and help Steve.
    Revolution Yes
    Member
    Last edited by Revolution Yes; Sun 23 Dec '07, 2:53am. Reason: typo

    Leave a comment:

  • Steve Machol
    Former Customer Support Manager

  • Steve Machol
    replied
    You are most likely using a table prefix for your MyBB database and did not add that to the source prefix setting in ImpExConfig.php.

    Leave a comment:

  • Revolution Yes
    Member

  • Revolution Yes
    replied
    Confused

    I've uploaded vB and Impex - I've also downloaded a backup of my source board which I want to test import - however it appears that there is no option for me to import the backup, only the live source board?

    I'm currently at the import Module 001 'Check & Update Database' stage. However I can't run the module as it brings up this message which I cannot advance from:

    Altering tables

    ImpEx will now Alter the tables in the vB database to include import id numbers.
    This is needed during the import process for maintaining refrences between the tables during an import.If you have large tables (i.e. lots of posts) this can take some time.

    They will also be left after the import if you need to link back to the origional vB userid.

    moderator - importmoderatorid OK
    usergroup - importusergroupid OK
    ranks - importrankid OK
    poll - importpollid OK
    forum - importforumid OK
    forum - importcategoryid OK
    user - importuserid OK
    style - importstyleid OK
    thread - importthreadid OK
    post - importthreadid OK
    thread - importforumid OK
    smilie - importsmilieid OK
    pmtext - importpmid OK
    avatar - importavatarid OK
    customavatar - importcustomavatarid OK
    customprofilepic - importcustomprofilepicid OK
    post - importpostid OK
    attachment - importattachmentid OK
    pm - importpmid OK
    usernote - importusernoteid OK
    phrase - importphraseid OK
    subscription - importsubscriptionid OK
    subscriptionlog - importsubscriptionlogid OK

    Valid found tables :


    Possibly custom tables or incorrect prefix :

    adminlog NOT found.
    adminoptions NOT found.
    announcements NOT found.
    attachments NOT found.
    attachtypes NOT found.
    awaitingactivation NOT found.
    badwords NOT found.
    banned NOT found.
    events NOT found.
    favorites NOT found.
    forumpermissions NOT found.
    forums NOT found.
    forumsubscriptions NOT found.
    helpdocs NOT found.
    helpsections NOT found.
    moderatorlog NOT found.
    moderators NOT found.
    polls NOT found.
    pollvotes NOT found.
    posts NOT found.
    privatemessages NOT found.
    profilefields NOT found.
    reportedposts NOT found.
    reputation NOT found.
    searchlog NOT found.
    settinggroups NOT found.
    settings NOT found.
    smilies NOT found.
    templates NOT found.
    templatesets NOT found.
    themes NOT found.
    threadratings NOT found.
    threads NOT found.
    threadsread NOT found.
    userfields NOT found.
    usergroups NOT found.
    users NOT found.
    usertitles NOT found.
    icons NOT found.

    If you have all red tables, i.e. none correct this could possible be your table prefix :


    mkp_gallery_ Failed Check database permissions and connection, or table prefix to ensure its correct
    My current concerns (well, two of many):

    1). (currently) I only want to test import my backup - this feels very 'live' to me
    2). How would I begin to resolve the above?

    Does anyone have any ideas?
    Revolution Yes
    Member
    Last edited by Revolution Yes; Fri 21 Dec '07, 6:16pm. Reason: added extra info

    Leave a comment:

  • Revolution Yes
    Member

  • Revolution Yes
    replied
    OK, thanks Steve that makes alot of sense and is much clearer.

    At the moment I'm trying to install vB - but I'm stuck at step 3 but it says i've got a database error:

    Database error in vBulletin :
    Cannot use database forum
    MySQL Error : Access denied for user 'lostco00_vbul'@'localhost' to database 'forum'
    Error Number : 1044
    Date : Friday, December 21st 2007 @ 02:42:50 PM
    Script : http://www.abc123abc123/forum/instal...all.php?step=3
    Referrer : http://www.abc123abc123/forum/instal...all.php?step=2
    IP Address : xx.xx.xxx.xx
    Username :
    Classname : vb_database
    Should I submit a ticket for this, or can anyone advise what I've done wrong I don't know why it's saying that I have no access to the DB when I successfully created it and given user all priveledges?

    (above script/referrer edited out for the purpose of security)

    EDIT:
    I resolved the above mentioned problem - turns out I didn't include the DB prefix
    Revolution Yes
    Member
    Last edited by Revolution Yes; Fri 21 Dec '07, 1:18pm.

    Leave a comment:

  • Steve Machol
    Former Customer Support Manager

  • Steve Machol
    replied
    I would not put vB in the same directory. What I would do is create a seprate directory, then once the import is done and everything is set, just change the mybb and vB directory names as you want them to be.

    Leave a comment:

  • Revolution Yes
    Member

  • Revolution Yes
    replied
    The live vB which I assume will be in the same directory as the current mybb forum (so I don't have to tell my users that the forum has been moved to a new URL)..basically I want to preserve the same URL location.

    But I think I know what you mean, thanks for your help for now.

    Leave a comment:

  • Steve Machol
    Former Customer Support Manager

  • Steve Machol
    replied
    When you do the real conversion you need to do it on the live vB.

    Leave a comment:

  • Revolution Yes
    Member

  • Revolution Yes
    replied
    Originally posted by Steve Machol View Post
    1.The only consistently reliable method of backing up and restoring a database is with shell access via telnet or ssh. This is because backing up with a PHP script like that in the Admin CP or phpMyAdmin can result in PHP timeout errors and an incomplete backup file.

    Please see the instructions here:

    Backup:
    http://www.vbulletin.com/docs/html/m...nce_ssh_backup

    Restore:
    http://www.vbulletin.com/docs/html/m...ce_ssh_restore

    If you don't have telnet or SSH access, some people have reported success with these scripts:

    MySQLDumper:
    http://www.mysqldumper.de/en/index.php

    MySQLHotxcopy:
    http://www.vbulletin.com/forum/showt...t=mysqlhotcopy
    OK, thanks, I will download mysqldumper and backup that way.

    2. You have to install the test vB in a different directory. You cannot install it in the same place you have your live vB.
    That makes sense, but what about when I come to do the 'real' conversion -will I have to install vb in a different directory or can I place it in the '/forums' directory which I currently use for Mybb?

    Cheers.

    Leave a comment:

  • Steve Machol
    Former Customer Support Manager

  • Steve Machol
    replied
    1.The only consistently reliable method of backing up and restoring a database is with shell access via telnet or ssh. This is because backing up with a PHP script like that in the Admin CP or phpMyAdmin can result in PHP timeout errors and an incomplete backup file.

    Please see the instructions here:

    Backup:
    http://www.vbulletin.com/docs/html/m...nce_ssh_backup

    Restore:
    http://www.vbulletin.com/docs/html/m...ce_ssh_restore

    If you don't have telnet or SSH access, some people have reported success with these scripts:

    MySQLDumper:
    http://www.mysqldumper.de/en/index.php

    MySQLHotxcopy:
    http://www.vbulletin.com/forum/showt...t=mysqlhotcopy

    2. You have to install the test vB in a different directory. You cannot install it in the same place you have your live vB.

    Leave a comment:

  • Revolution Yes
    Member

  • Revolution Yes
    replied
    (I hope this isn't considered a bump which is frowned against - it's just that my above circumstances have changed as I am now ready to test import.):

    I've just purchased a vB license and have read the manual here: http://www.vbulletin.com/docs/html/impex_module_dump

    Can I just clarify a few things?

    1) I want to do a test import first so that I can leave my board running just in case something goes wrong. Now, do I use a backup done in Cpanel or in myphpadmin?

    2) The members area has this notice:
    To enable this option we require you to enter the URL of where your forums are installed or where you intend to install them. Please use the Edit License or Submit URL links.
    However I want the conversion to be in the same place (same url) where my current forum is - How can I install vB on this url to do a test conversion, when my current board is still live?

    Thanks in advance for any help.

    Leave a comment:

  • Revolution Yes
    Member

  • Revolution Yes
    replied
    Thanks Steve, I think i'll do a test conversion using a back-up and then discard that test conversion and do the real one (which would require closure of my source forum during this process) if that test attempt goes well.

    Cheers.

    Leave a comment:

  • Steve Machol
    Former Customer Support Manager

  • Steve Machol
    replied
    You would have to restore that test backup to a live database, but yes you can do that.

    Leave a comment:

widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X