Announcement

Collapse
No announcement yet.

Just ran vb_test.php script and got error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Just ran vb_test.php script and got error

    This is the error I got when I ran the test. What doe is mean?

    Fatal error: Call to a member function on a non-object in /homepages/44/d156178506/htdocs/pennmustangs.com/vb_test.php on line 222


    Thanks in advance.

  • #2
    Does your server have MySQL installed? Have you tried reuploading the script?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Yes it does have MySQL installed. Only thing I uploaded to my site is the vb_test.php file stated above. Entered my MySQL login information and that is when that error came up. I am using 1and1.com as my hosting company.

      Comment


      • #4
        It means the MySQL information is incorrect, I've just updated vb_test.zip to show this more clearly.
        Scott MacVicar

        My Blog | Twitter

        Comment


        • #5
          Hi,

          I got this error:

          Fatal error: Trying to clone an uncloneable object of class mysqli in /home/donatas/public_html/vb_test.php on line 56

          Mysql is working fine (I have a running phpbb forum and cms).
          PHP 5.1.6
          MySQL 5.0.26


          PHP Code:
          {
          case 
          'mysql':
          $obj = new mysql($host$user$password$dbname);
          return (
          $obj->connection_resource $obj false);
          case 
          'mysqli':
          $obj = @new mysqli($host$user$password$dbname);
          if (
          mysqli_connect_errno())
          {
          $db_connection_error mysqli_connect_error();
          return 
          false;
          }
          return 
          $obj;

          Why it skips mysql?
          Last edited by Fenixoid; Fri 9 Feb '07, 9:00am.

          Comment


          • #6
            Anyone?

            Comment


            • #7
              Can you show me your phpinfo settings please, we try to use MySQLi if its available since its the newest version of the interface available which gives greater functionality.

              I've tested the code on PHP 5.2.1 without problem and I'm about to go to test on 5.1.6.
              Scott MacVicar

              My Blog | Twitter

              Comment


              • #8
                You're host has zend.ze1_compatibility_mode enabled, this will need to be turned off since it can cause errors when using internal classes in PHP.

                This is off by default and no longer exists in PHP 6.
                Scott MacVicar

                My Blog | Twitter

                Comment


                • #9
                  Originally posted by Scott MacVicar View Post
                  You're host has zend.ze1_compatibility_mode enabled, this will need to be turned off since it can cause errors when using internal classes in PHP.

                  This is off by default and no longer exists in PHP 6.
                  That's was the problem, thanks

                  Another one: should safe mode by on or off? I pass everything, but at safe mode it says "Fail".

                  Code:
                   
                  box ~ # cat /etc/php/apache2-php5/php.ini | grep safe_mode
                  safe_mode = On
                  safe_mode_gid = On

                  Comment


                  • #10
                    You will be able to run vB with safe mode on, but you will have to take some extra steps for file uploads to work, and you will not be able to store attachments and avatars in the file system. They will have to be in the database.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      Just ran the script on my server and got a bunch of fails. http://pennmustangs.com/vb_test.php

                      Hosting is through 1and1.com Do you recommend a good hosting site to run vB on?
                      Last edited by SVTCobraLTD; Sun 18 Feb '07, 8:23am.

                      Comment


                      • #12
                        there is a lot of discussions regarding hosting a vBulletin forum,.... please take a look at the existing discussions before starting a new.
                        oh no, i'm not going with Xenforo... come on, i'm better than that... i stick with Wordpress... rofl

                        Comment


                        • #13
                          vb_test woes...

                          I have a server with the recommended software config on it, have created a dedicated database on our MySQL server, and a user account that has ALL privileges granted on the one database that I want to run vB against (I don't want it to have global ALL privileges as there are other systems on that server using MySQL as well). When I run the vb_test script, all the MySQL test fail:

                          Essential vBulletin RequirementsPHP5.2.3PassMySQLFailPCREPassmagic_quotes_sybasePassXMLPassDatabase Connection Error: Access denied for user 'vbulletin_test'@'localhost' (using password: YES)MySQL Permission RequirementscreateFailalterFailinsertFailupdateFailselectFaildeleteFaildropFailRecommended Settings (Optional)GD2.xPassopen_basedirPasssafe_modePassGZIPPassmagic_quotes_runtimePassmagic_quotes_gpcFailpcre.backtrack_limitPassOverall Result:Fail

                          My user privileges are as follow (from phpMyAdmin):

                          vbulletin\_testSELECT, INSERT, UPDATE, DELETE, CREATE, DROP, REFERENCES, INDEX, ALTER, EXECUTE YesNo

                          Why am I getting these errors from the test script?

                          Thanks!

                          -R

                          Comment

                          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                          Working...
                          X