Announcement

Collapse
No announcement yet.

initial server requirements/server testing

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • initial server requirements/server testing

    Hi there. Im VERY new to this so I apologize in advance if this is a stupid quesiton. I browsed the faq's and the forums for a while but cant quite seem to find what Im looking for.

    I wanted to make a board and Ive been memebers of boards that use vbulletin so I decided to go that route since I like it.
    I installed a server (windows 2003 Server), and today installed the latest php and mysql. I think. Again, Im a unix/cisco person not an MS/php/sql person!

    Everything seemed to go according to plan, but I downloaded the vb_test.php script and now I have no idea in the world what to do with it.
    How do I know my server is configured correctly? Php ok? Mysql ok? Im completely in the dark. If there were a doc out there that could walk me through it like I was 2 years old, it would be great

    Thank you a ton for your help in advance.
    bob

  • #2
    You run it from your browser, i.e.,

    http://www.yoursite.com/vb_test.php
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      If you are more of a unix person consider running vBulletin on a unix platform with php / mysql.

      You drop the script into the location that IIS wants your documents to go and then just execute it via the browser as Steve has said.
      Scott MacVicar

      My Blog | Twitter

      Comment


      • #4
        Thanks steve.. I guess I failed miserably somewhere then. When I throw it into my document root directory I get the generic:
        he page cannot be found

        The page you are looking for might have been removed, had its name changed, or is temporarily unavailable. Please try the following:
        • Make sure that the Web site address displayed in the address bar of your browser is spelled and formatted correctly.
        • If you reached this page by clicking a link, contact the Web site administrator to alert them that the link is incorrectly formatted.
        • Click the Back button to try another link.
        HTTP Error 404 - File or directory not found.
        Internet Information Services (IIS)



        Any ideas where to look next?


        As for just doing it on unix, unfortunately I cant in this case, it has to be IIS due to the fact that the people supporting it are not unix literate at all. Besides it will force me to learn more windows stuff

        Comment


        • #5
          Have a quick read on http://www.iis-resources.com/modules...php?storyid=96

          I think AWS posted a tutorial somewhere too.
          Scott MacVicar

          My Blog | Twitter

          Comment


          • #6
            Ahhhh!

            Thanks Scott, great! Im slowly getting there. Looks like I have IIS running OK and PHP for the most part which is good.

            When I run the vb_test.php in netscape I get the frame but then some strange code underneath it. When I run it in IE, it displays correctly but none of the mysql fields are filled in which makes sense because I didnt do anything with mysql yet.

            In either browser though, the logo on the top left does not appear. (not sure if it matters or not)
            Now Ill get on with configuring mysql... Ill scour this site to see if there are any good how-to's to make it play nice with vb

            Comment


            • #7
              There appears to be a problem with the server the test script images are on, it will get looked at tomorrow morning when the person with access can check.
              Scott MacVicar

              My Blog | Twitter

              Comment


              • #8
                oh ok its not me then Thanks.

                Also, I went throught the vbulletin docs, and it does show how to create a mysql user etc, however it is for unix, not windows. I cant seem to find out how to set up mysql for windows to get it ready for vbulletin anywhere. Have a link handy?

                Id really love to get this squared away so I can download vbulletin and start playing with it.
                Thanks!
                bob

                Comment


                • #9
                  You probably want the Windows Administrator for MySQL, most people dont have access for that

                  http://dev.mysql.com/downloads/administrator/1.1.html

                  The Setting up a MySQL user item on vBulletin applies to Windows too but you do it through a command prompt, and instead of /usr/local/mysql/bin/mysql its c:\mysql\bin\

                  I'll edit that shortly.
                  Scott MacVicar

                  My Blog | Twitter

                  Comment


                  • #10
                    Edited the documentation to include details on how to create a database from the Windows Command Prompt.
                    Scott MacVicar

                    My Blog | Twitter

                    Comment


                    • #11
                      Got it thank you Just logged in with it, Ill poke around to see what it can do for me. Already added a new user 'php'... vb_test.php still fails though, so Ill keep reading

                      Comment


                      • #12
                        How does it fail?
                        Scott MacVicar

                        My Blog | Twitter

                        Comment


                        • #13
                          Well now that I went through your windows install, it passes everything! woo hoo!
                          One question though, in the install page it mentions I need to add the server info to config.php. I dont have that file... so I assumed you meant php.ini and I put those lines in there.
                          However when I rebooted to make sure all the services come up ok it had errors parsing php.ini at those lines
                          At least it passes now!
                          Before I go further I need to document what I have a little better, and understand a few things first. Then I can try out vbulletin and get that going. Thank you a ton for your help, Im sure you'll be hearing from me more

                          Comment


                          • #14
                            config.php is the vBulletin install file when you've purchased a copy.

                            Remove what you added php.ini as it will cause errors.

                            If you document it all feel free to post it in the server configuration forum, I'm sure future customers would appreciate it.
                            Scott MacVicar

                            My Blog | Twitter

                            Comment


                            • #15
                              Got it thanks. I sure will post there once I get it configured and running, thats a great idea.
                              I just went to purchase it but had 2 questions:

                              1) To debrand it, I really dont need to at this point, but if I decide later, can it be done without jumping through major hoops later?

                              2) Do I need to purchase the phone support now or can i get that later as well.

                              thanks!
                              bob

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X