Announcement

Collapse
No announcement yet.

PHP Fatal error when running vb_test.php

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • PHP Fatal error when running vb_test.php

    Hello

    I'm setting up my server for VBulletin 3.0.3 (newbie at all this so I want to make sure it will install before purchasing!), and I get the following error when I run vb_test.php:

    PHP Fatal error: Call to undefined function mysql_connect() in C:\Tbird Site\vb_test.php on line 113

    I read in a couple other posts that php was compiled without mysql support, but I don't think that's my problem (and if it is I don't know how to solve it).

    Some background:
    Server - Win2003, IIS 6.0.

    Php 5.0.2 - installed from php-5.0.2-Win32.zip (which to my understanding supports mysql), installed as CGI. Used php.ini from php.ini-recommended and made the follwing changes:
    extension_dir = "C:\php\ext"
    cgi.force_redirect = 0
    extension=php_mysqli.dll

    MySQL 4.1.7, installed from mysql-4.1.7-essential-win.msi

    Added the following to PATH - C:\php;C:\php\ext;C:\Program Files\MySQL\MySQL Server 4.1\bin;

    I can connect to my database using the c:\>mysql -h localhost -u user -p command.

    The website, which consists of 3 php scripts - test.php, vb_test.php, and database_conflicts.php (haven't even looked at that one yet), can parse php files, as test.php runs fine.

    Any help would be much appreciated!

    Kevin

  • #2
    did you open up vb_test.php and configure the MYSQL information?
    ManagerJosh, Owner of 4 XenForo Licenses, 1 vBulletin Legacy License, 1 Internet Brands Suite License
    Director, WorldSims.org | Gaming Hosting Administrator, SimGames.net, Urban Online Entertainment

    Comment


    • #3
      Nope - what do I need to edit (wasn't kiddign about being a newb )?

      Comment


      • #4
        Hi,

        Although you will need to do as ManagerJosh suggested as well, the problem is that you have the MySQLi (MySQL "Improved") extension installed, not the standard MySQL extension. You need another line in your php.ini which reads:

        extension=php_mysql.dll (note the "i" has been removed)

        This will enable the old MySQL PHP extension which is what vb_test.php uses

        Thanks,
        Alan.

        Comment


        • #5
          Thanks, that let the script run. However, all of the mysql permissions fail, and I get the following warning:

          PHP Warning: mysql_connect() [function.mysql-connect]: Client does not support authentication protocol requested by server; consider upgrading MySQL client in C:\Tbird Site\vb_test.php on line 113

          The user has all permissions for the database, and I just verified that I could create and drop a table via the mysql command line.

          It also failed GD under the Recommended Settings.
          Any ideas?
          Last edited by Tbird66; Fri 10 Dec '04, 7:22am.

          Comment


          • #6
            You need to reset your password to the oldstyle within MySQL. MySQL 4.1.X uses a new password storage hash and the php_mysql.dll file doesn't understand it.

            http://dev.mysql.com/doc/mysql/en/Old_client.html

            There is also a bug in MySQL 4.1.7 that occurs with heap tables under load so that can cause problems with vBulletin.

            In order for GD to pass, you would have to enable it in your PHP.INI file as well.
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud demonstration site.
            vBulletin 5 API

            Comment


            • #7
              Passed all tests - thanks!

              My forum shouldn't see heavy traffic, as it's site for a local vintage tbird club - I expect ~ 20 users. Does the heap table bug manifest under any load or only when large temp tables are created? Do I need to look for an older version of mysql at this point?

              Thanks again!

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X