Announcement

Collapse
No announcement yet.

vBulletin 3.8.7 downloads from the members area

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • vBulletin 3.8.7 downloads from the members area

    Since I can't post anywhere because I don't have an active license (plenty of expired ones though), I'm going to put this in here... Scratch that, but I'm still leaving this here

    There doesn't seem to be anywhere I can download any vBulletin less than vB 3.8.7 PL3 in the members area. I can download 3.8.6 right down to vB 2 but all I have for 3.8 is the patch files. Now patched files are all well and good if you just want to overwrite everything, but when you've got heavily modified source code being able to diff between the standard PL2 and PL3 releases to manually patch your files would be the ideal way to do this. Since there is no diff supplied in the release, and I can't get a copy of vB 3.8.7 PL2 from the members area, I'm effectively being hamstrung. Can this be remedied?

  • #2
    vb 3.8.7 PL3 is the only available download for vb3.8.7 for anyone that has access to that version.

    Why can't you just download the PL3 package and compare it against what you already have?

    There are differential tools available that you can set to ignore the header and footer of each file and therefore only comparing the meat of each file.

    PS: I believe you should be able to post in the support forums as long as you have licenses in your members area. Unless, your forum account here isn't associated with your customer account. (I could be wrong, but I recall people with expired VB3 licenses posting in various areas...)
    To be updated...

    Comment


    • #3
      Originally posted by ENF View Post
      Why can't you just download the PL3 package and compare it against what you already have?)
      Because I'm not sure what's stock vB PL2 code and what's been modified by the older, long since departed devs. This is why a diff between PL2 and PL3 is desirable.

      As for the license issue, it's been resolved; I can post elsewhere now

      Comment


      • #4
        Originally posted by TouchingVirus View Post
        Since I can't post anywhere because I don't have an active license (plenty of expired ones though), I'm going to put this in here... Scratch that, but I'm still leaving this here

        There doesn't seem to be anywhere I can download any vBulletin less than vB 3.8.7 PL3 in the members area. I can download 3.8.6 right down to vB 2 but all I have for 3.8 is the patch files. Now patched files are all well and good if you just want to overwrite everything, but when you've got heavily modified source code being able to diff between the standard PL2 and PL3 releases to manually patch your files would be the ideal way to do this. Since there is no diff supplied in the release, and I can't get a copy of vB 3.8.7 PL2 from the members area, I'm effectively being hamstrung. Can this be remedied?
        Modifying your files is something you do at your own risk. It isn't supported by us. We recommend people use the Hooks and Plugins system and not edit the files. If you do edit the files, you should create an archive of both the before and after. Whether you use folders or SVN is up to you.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API - Full / Mobile
        Vote for your favorite feature requests and the bugs you want to see fixed.

        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X