Announcement

Collapse
No announcement yet.

Mobile style

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • slinky
    replied
    Unfortunately it doesn't work for me. I had a site up that is supposed to be viewed only in mobile browsing mode in a limited width iframe. The user gets there and is sent to the url in the iframe of:

    mysite.com/forum/forumdisplay.php?f=2&styleid=6

    On the first page it shows the mobile style properly. On the next pages that follow, the style reverts back to the main. With the fix above, at least the style isn't reverting back to the main style and is staying on style 6. Unfortunately in the iFrame version, the first page shows style 6 and then every click goes back to the main desktop theme. Might have to do with the iFrame relationship with the cookie set, not sure.

    Regarding the mobile style here, unfortunately it leaves an incredible amount to be desired. Navigation is horrendous and, to be honest, my users so overwhelmingly prefer Dartho's that there was not even a thought here as to which one to use.
    Last edited by slinky; Wed 18th Jan '12, 3:45pm.

    Leave a comment:


  • Wayne Luke
    replied
    Yep.. Its a bug. Listed in this very thread. The Jira issue linked above even has the code fix for it. Will be distributed in 4.1.11.

    Not sure what else your asking for.

    Leave a comment:


  • slinky
    replied
    I agree 200% with Mark.

    The problem I'm having with Dartho's style (or any for that matter) is that if I am trying to use a style - let's say on the desktop - and I choose "style=xx" for browsers, the moment they leave the first page it reverts to the other style. This started happening with vb 4.1.9. I thought I saw Dartho post on this but can't find it.

    Leave a comment:


  • Trevor Hannant
    replied
    Originally posted by carntheroos4eva View Post
    You should have the styles on none... That's why it's stuffing up on you.
    Eh?

    Leave a comment:


  • carntheroos4eva
    replied
    You should have the styles on none... That's why it's stuffing up on you.

    Leave a comment:


  • shri
    replied
    This two-line fix should solve the problem: http://tracker.vbulletin.com/browse/...#action_133539

    Leave a comment:


  • Wayne Luke
    replied
    Originally posted by mk132 View Post
    This also happens at times when JavaScript is enabled.
    I was referring to the specific issue link that is in my quote.

    Leave a comment:


  • mk132
    replied
    Originally posted by Wayne Luke View Post
    You cannot use the Mobile Style with Javascript turned off. It relies on Javascript to function. I doubt this will change as it is built entirely on a Javascript module.
    This also happens at times when JavaScript is enabled.

    Leave a comment:


  • punchbowl
    replied
    Originally posted by Mitzy View Post
    Well its a real bug and the only way I can fix it is to switch off mobile view.
    Could you not just enable javascript?

    internet>menu>options>more>settings>enable javascript

    Leave a comment:


  • Mitzy
    replied
    Well its a real bug and the only way I can fix it is to switch off mobile view.

    Leave a comment:


  • Wayne Luke
    replied
    Originally posted by mk132 View Post
    This looks like the bug I reported today. Maybe you can convince them that it is important; I certainly couldn't.
    You cannot use the Mobile Style with Javascript turned off. It relies on Javascript to function. I doubt this will change as it is built entirely on a Javascript module.

    Leave a comment:


  • mk132
    replied
    This looks like the bug I reported today. Maybe you can convince them that it is important; I certainly couldn't.

    Leave a comment:


  • punchbowl
    replied
    I've seen this posted a couple of times by different people but I cannot recreate either. I have a htc desire too incidentally.

    Leave a comment:


  • Joe D.
    replied
    I can't reproduce on my Droid Charge- stock browser. When I click on Full Site it stays on full site even after clicking on other pages/threads.

    Do you have cookies enabled?

    Leave a comment:


  • Mitzy
    replied
    Yeah the mobile style is style trying to ruin my life.

    Android HTC Desire (STOCK).

    Leave a comment:

widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X