Announcement

Collapse
No announcement yet.

Members Area Down?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by Zachery View Post
    No, the original purchaser is always the owner untill the license is transfered.
    Ok I will try to contact him.

    Comment


    • #17
      Originally posted by Zachery View Post
      If you're having a problem with safari its because your password has been changed and its no longer valid, but safari keeps trying the old password untill the server drops the connection. You need to go into your keychain and remove that login.
      I'm afraid the problem is on your member site and not on Safari. You send the HTTP status code 401 Unauthorized but not the required response header field WWW-Authenticate.

      See RFC 2616 section 10.4.2:
      401 Unauthorized

      The request requires user authentication. The response MUST include a WWW-Authenticate header field...
      If you sent the WWW-Authenticate header field, Safari would ask for username and password.
      Babelboard

      Comment


      • #18
        Not sure why you're not getting WWW-Authenticate because it is sent and I can see it when I analyze the headers:
        Code:
        HTTP/1.x 401 Unauthorized
        Date: Fri, 21 Mar 2008 10:24:03 GMT
        <snip>
        WWW-Authenticate: Basic realm="vBulletin Members Area: Please enter your customer number and customer password:"

        Comment


        • #19
          Originally posted by Mike Sullivan View Post
          Not sure why you're not getting WWW-Authenticate because it is sent and I can see it when I analyze the headers:
          Code:
          HTTP/1.x 401 Unauthorized
          Date: Fri, 21 Mar 2008 10:24:03 GMT
          <snip>
          WWW-Authenticate: Basic realm="vBulletin Members Area: Please enter your customer number and customer password:"
          I don't know why the header once is sent and another time not. It works fine on Firefox (seen in LiveHTTPHeaders add on), but on Web-Sniffer and Safari there is no WWW-Authenticate header sent. Could it be that there are any browser switches in the script?
          Babelboard

          Comment


          • #20
            There is one other different in the response headers. With Web-Sniffer and Safari I get "X-boxen: web1" and with Firefox "X-boxen: web2". Are there different servers with different scripts?
            Babelboard

            Comment


            • #21
              Web-Sniffer refuses to show it for that URL, but other viewers show it without any problem.

              And I checked whether it was being sent to my local copy of Safari via Wireshark and it shows up fine.

              The web1/web2 difference is a server difference, but they host the same script.

              Comment


              • #22
                You are right, the WWW-Authenticate header is sent by your server. The problem probably is that there are colons in the header value:
                Code:
                WWW-Authenticate: Basic realm="vBulletin Members Area: Please enter your customer number and customer password:"
                This is allowed according to RFC 822 but clients could have problems with it. I corrected this bug in Web-Sniffer but the problem has probably something to do with Safari. Could you remove the colons to test it?
                Babelboard

                Comment


                • #23
                  Good catch. I've removed the colons if you want to try it again.

                  Safari 3.0.4 on Windows is still refusing to show me a realm though.

                  Comment


                  • #24
                    Originally posted by Mike Sullivan View Post
                    Good catch. I've removed the colons if you want to try it again.
                    With Safari 3.1 Mac it works fine now.
                    Babelboard

                    Comment


                    • #25
                      I've never had any problems with Safari on the Mac or PC. 3.0 or 3.1. I tried to reproduce this but couldn't.

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X