Announcement

Collapse
No announcement yet.

Avatar Upload Problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Dale Coffing
    replied
    I am a new user of vBulletin and noticed this exact problem also. I tried changing the size of the pixels and the size of the file in the AdminCP and it still won't allow me to upload the avatar. Do I have to wait for a period of time before attempting the upload? I tried changing the value once temporarily to a larger pixel size and it worked but now it doesn't...

    Leave a comment:


  • electrobase
    replied
    JamesUs:

    I believe BBInsider makes a valid point. If this happens at least occasionally, even if it is a PHP problem, it is a common PHP problem, and it would be tremendously supportive of the vB community if you could post the PHP fix for this - it may be outside the purview of vB, but it affects many vB users, and if vB (or Jelsoft) or you, can suggest the non-vB PHP fix, that would help many vB users.

    Thanks again for the time you have already spent on this.

    Leave a comment:


  • JamesUS
    replied
    If your error referenced the php.ini file, then it is a PHP error and not a vBulletin error.

    Here is the way it works;

    vB gets a request to accept an avatar upload. It compares the sizes to the ones set in it's options. If those fail, then it throws up a 'vBulletin Message'. Else it carries on.
    Then PHP checks it against the sizes in PHP.ini. If they fail it shows a PHP error message. If they pass, then it is given back to the script to process.

    Leave a comment:


  • electrobase
    replied
    vBulletin doesn't even look at the limit in php.ini. All we use is the limit in the control panel.
    I continually got an error that referenced the limitation in php.ini. We changed the value in php.ini, and the error message referenced the new value in php.ini. We increased the value in php.ini to allow the file upload size we wanted, and were able to upload.

    You have a strange definition of coincidence. I have seen numerous posts about this problem, and different speculations about a possible fix, but no definitive answer. In our situation, changing the value in php.ini changes the vBulletin error message, AND fixes the problem.

    If this is a coincidence, and is not the true solution, then I would dearly love to hear what the true solution is, because there IS a problem - I have seen too many posts to believe otherwise.

    Thanks all of you, for being interested in this problem.

    Leave a comment:


  • BBInsider
    replied
    James, if it happens to more then one board, I seen a few posts about this, I would think its a small bug...? no?

    Leave a comment:


  • JamesUS
    replied
    vBulletin doesn't even look at the limit in php.ini. All we use is the limit in the control panel.

    If the php.ini limit was the problem, you'd be getting PHP errors rather than vB ones. Perhaps it was just coincidence?

    Leave a comment:


  • electrobase
    replied
    We actually got this fixed on electrobase. (courtesy of my host, viaVerio.com): the php.ini has a limit of 2 M - PHP (or vBulletin) interprets this as 2 bytes, and ignores the M. If you want 50K, change the value in php.ini to 50,000 (I think without the comma). We were being thrown off because there is like a 24 hour delay between changing the value in php.ini on our site, and the change taking effect - but it does eventually take effect.

    short summation: ignore the M in php.ini, and input the total bytes desired (i.e. 50000000 for 50 M)

    I have read enough posts about this, that it seems this should be documented or fixed.

    Leave a comment:


  • BBInsider
    replied
    I've been getting that from day one.

    Leave a comment:


  • electrobase
    replied
    We are also running into this problem. Somehow, something is interpreting the 2 M limit in php.ini as 2 bytes. It doesn't matter what we set in vBulletin, it tells us we have exceeded the 2 byte limit.

    Any ideas?

    Leave a comment:


  • Jordan
    replied
    Yeah, it works fine for me as well...

    Leave a comment:


  • Freddie Bingham
    replied
    Oh doh but your avatar works fine for me.

    Leave a comment:


  • KeithMcL
    replied
    "The file that you have tried to attach is too big. The maximum size is 20000 bytes." is the error.

    The avatar file is only 3774 bytes.

    Leave a comment:


  • Mike Sullivan
    replied
    Which error message are you getting? Dimensions?

    Leave a comment:


  • KeithMcL
    replied
    Originally posted by freddie
    Are you sure you put in 20000 bytes and not 2000?
    I'm talking about on these forums. Are you?

    Leave a comment:


  • Freddie Bingham
    replied
    Are you sure you put in 20000 bytes and not 2000?

    Leave a comment:

widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X