Announcement

Collapse
No announcement yet.

Install fails: Field 'afterforumids' doesn't have a default value

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Install fails: Field 'afterforumids' doesn't have a default value

    Code:
    Database error in vBulletin 3.6.8:
    
    Invalid SQL:
    INSERT INTO pt_project
        (title, summary, description, displayorder, title_clean, summary_clean)
    VALUES
        ('Default Project', 'This is a short summary of the project.', 'This is a description of the project. You may wish to discuss things like goals, timelines, and responsibilities here.', 1, 'Default Project', 'This is a short summary of the project.');
    
    MySQL Error  : Field 'afterforumids' doesn't have a default value
    MySQL 5.1

  • #2
    It's not supposed to have a default value. What are you doing when you get this error? Have you installed any modifications other than the PT and Blog?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      The error happens when the installer is running. I tried dropping every table starting with pt_ and reinstalling, but that didn't fix it.

      I also tried disabling all of my other products (confirmed all plugins show as "crossed out"). Same error.

      Comment


      • #4
        Fill out a support ticket at:

        http://members.vbulletin.com/members...ontactform.php

        Please include a complete description of the problem and be sure to include the login info to your Admin CP, phpMyAdmin and FTP in the 'Sensitive Data' field.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          You're using MySQL's strict mode. You need to disable that using the option in config.php (you should get a warning about it when you login to your control panel).

          Comment


          • #6
            That resolved the error.

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X