Announcement

Collapse
No announcement yet.

XHTML Compliancy...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • XHTML Compliancy...

    In an attempt to make our website xhtml compliant, sitewide...I have run across a problem with one of the blog pages. That page being: Best Blogs

    The above referenced page has 20 errors. Mostly due to IDs already defined. Here's the link to the validated page: W3C

    Now...I'm not sure what's causing the issue, but all other blog pages validate except for this one.

    If someone needs me to enable the template names in the HTML output...just let me know and I'll oblige.

    I could sure use all the help I can get...

    Thanks, in advance...
    Free Computer Help
    sigpic

  • #2
    This would be due to your customized style. The default vBulletin Best Blog list does validate.

    http://validator.w3.org/check?uri=ht...Inline&group=0

    I would suggest removing the IDs that are making your page not validate and switching them to classes if they are needed for styling purposes.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API

    Comment


    • #3
      Thanks, Wayne...

      Done and done...all seems to be golden.
      Free Computer Help
      sigpic

      Comment


      • #4
        Wayne...

        I spoke too soon. I use a template mod from vbulletin.org. I have posted there, as well. The page in question returns one error...where the ID has already been defined. It is defined in the navbar from some code the developer of the mod said I should try because the blog popup menu wasn't showing on his pages. This code was inserted into the navbar template and contains the following...please note the blog_navbar_link_menu template contains the same code...so, no matter what I've tried, the popup either gets disabled on his template pages or the forum pages.

        Here's the line of code:

        Code:
        <div class="vbmenu_popup" [COLOR=Red]id="vbbloglinks_menu"[/COLOR] style="display:none;margin-top:3px" align="$stylevar[left]">
        The problem is the code in red above.

        It is in the navbar template, as well as the blog_navbar_link_menu template of the style I am using. You stated to remove or change it to a class. If I remove it from either...I have the problem stated above.

        How would I change it to get the page to validate? It's the only error on the page. With this correction...I will have succeeded in making the entire site XHTML compliant.

        I certainly appreciate any help you have to offer with this...
        Free Computer Help
        sigpic

        Comment


        • #5
          The addon should change the ID to something like vbbloglinks_menu2, duplicate the corresponding drop down code and associate it properly. There are tutorials on how to make dropdowns in the article section at vBulletin.org.
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud demonstration site.
          vBulletin 5 API

          Comment

          Related Topics

          Collapse

          Working...
          X