Announcement

Collapse
No announcement yet.

Installing Blog - Sorry, no XML was passed into this function and the $path variable

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Installing Blog - Sorry, no XML was passed into this function and the $path variable

    I looked around to see if anyone else has had this problem, and I couldn't find it.

    I'm on Windows Server 2003.

    I just installed 3.8.1 as a fresh, new install and I wanted to install the blog before I get the site up and running.. just in case there are any issues.


    After I click on "Import Products" ./includes/xml/product.xml, I see this:

    Sorry, no XML was passed into this function and the $path variable empty

    Thanks!
    -Ben

  • #2
    That is the wrong XML file for the Blog. It should be product-vbblog.xml.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Correct... I went in an copied it (the wrong thing) after I had already tried it (the correct xml string) several times:

      Here's what it says in the pop up window:

      You did not specify a file to upload, so vBulletin will attempt to import the file

      ./includes/xml/product-vbblog.xml

      from the server's file system.

      Are you sure?

      Comment


      • #4
        Then proceed.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Sorry, I should be more specific... After I "Proceed". I get:


          vBulletin Message

          Sorry, no XML was passed into this function and the $path variable empty

          Comment


          • #6
            This means that either you have not uploaded that file correctly, or your PHP is not properly configured for XML support.

            Reupload the Blog files and make sure that all of them, including the .xml file, are uploaded in ASCII format. Also make sure you overwrite the ones on the server.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Hi Steve,

              I actually downloaded the zip file directly on the server, using remote desktop.

              I extracted the files into a folder, and then copied them into my forums folder.

              I didn't FTP any file, including the original install files for vBulletin. So I'm wondering if maybe my problem IS the PHP.

              I've re-installed vBulletin several times, and copied the blog files over several times as well.

              Comment


              • #8
                My setup:

                Server Type WINNT
                Web Server isapi
                PHP 5.2.8
                PHP Max Post Size 8.00 MB
                PHP Maximum Upload Size 2.00 MB
                PHP Memory Limit 128.00 MB
                MySQL Version 5.1.31-community
                MySQL Packet Size 1.00 MB

                Comment


                • #9
                  Enable phpinfo in the Admin CP, then provide the URL to your forums. This may help us troubleshoot this problem.

                  Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Public phpinfo() Display Enabled
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    Thanks Steve,

                    It's: http://www.centralilweddings.com/forums

                    Comment


                    • #11
                      Assuming you have uploaded the files correctly, then my best guess is that 'SimpleXML' is the problem. You will need to reinstall PHP with full XML support.
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #12
                        This one just bit me on the Win2k3 server I'm working on right now. Posting for future reference.

                        Check the file permissions. Since the files are on your server, they need to have at least read access for the "internet guest account", which will start with "IUSR_". If you don't grant this access, vB will throw this error message.

                        Comment

                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                        Working...
                        X