Announcement

Collapse
No announcement yet.

Database error on blogs rss feed

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • lifanovsky
    replied
    Sorry for bothering, I solved this, though I have no idea, how exactly. I removed the calls to blog_external.php from header template and put it back to where it was before - forumhome tamplate. And everything started to work. I guess there were some problems with the modules and/or with hooks - though right now I totally have no desire to dig into what exactly caused the problem.

    Freddie, thank you for answering!

    Leave a comment:


  • lifanovsky
    replied
    Right, then I enabled it back. I have an rss parser that I use to show latest blogs entries on main page. I use modules for that. When I disable it, I get DB error. When I enable it global_start hook I get DB error. When I enable it with forumhome_start hook, I get blank page. Seems crazy to me cos I don't understand why changing hooks changes behaviour of the script when I call it directly...
    Last edited by lifanovsky; Fri 23 Jan '09, 2:59pm.

    Leave a comment:


  • Freddie Bingham
    replied
    If you disabled all hooks then you disabled the blog itself, hence the problem with that file now.

    Leave a comment:


  • lifanovsky
    replied
    I tried to disable hooks on forum. After that, when I try to call blog_external.php, it tells me
    Fatal error: Call to undefined function prepare_blog_category_permissions() in /path/to/http/includes/blog_init.php on line 30

    What can that mean?

    Leave a comment:


  • lifanovsky
    replied
    Thank you Freddie. Actually I didn't do any customizations for the blog - how do I figure out where to find and eliminate this code?

    Leave a comment:


  • Freddie Bingham
    replied
    Looking at blog_external.php, seems like you have some code in the blog_external_query hook that is the problem.

    Leave a comment:


  • Steve Machol
    replied
    There is no 'forumid' field in the default vB blog tables. That is from a bad file or a third-party add-on you installed.

    Leave a comment:


  • lifanovsky
    started a topic Database error on blogs rss feed

    Database error on blogs rss feed

    Hello!

    Yesterday I have found that everytime I try to access either all blog's RSS feed or some specific blog's feed, it gives me a database error. In fact, everytime I try to access http://www.forumklassika.ru/blog_external.php it gives me a db error. I tried to repair DB several times but it doesn't help. What can be the problem and how do I solve it?

    Thank you very much in advance!

    UPDATE:

    That's the text from errorlog:

    Invalid SQL:

    SELECT blog.*, blog_text.*, user.*

    FROM blog AS blog
    INNER JOIN blog_text AS blog_text ON (blog.firstblogtextid = blog_text.blogtextid)
    INNER JOIN blog_user AS blog_user ON (blog_user.bloguserid = blog.userid)
    LEFT JOIN user AS user ON (user.userid = blog_text.userid)


    WHERE 1=1
    AND blog.state = 'visible'
    AND blog.dateline <= 1232637540
    AND blog.pending = 0
    AND blog_user.options_guest & 1
    AND ~blog.options & 8
    AND thread.forumid!='53' AND thread.forumid!=' 16' AND thread.forumid!=' 18' AND thread.forumid!=' 59' AND thread.forumid!=' 61' AND thread.forumid!=' 62' AND thread.forumid!=' 108'


    ORDER BY blog.dateline DESC
    LIMIT 30;

    MySQL Error : Unknown column 'thread.forumid' in 'where clause'
    Error Number : 1054
    Request Date : Thursday, January 22nd 2009 @ 06:19:00 PM
    Error Date : Thursday, January 22nd 2009 @ 06:19:00 PM
    Script : http://www.forumklassika.ru/blog_external.php
    Referrer :
    IP Address : 217.10.40.44
    Username : Unregistered
    Classname : vB_Database
    Last edited by lifanovsky; Thu 22 Jan '09, 6:21am.

Related Topics

Collapse

Working...
X