Announcement

Collapse
No announcement yet.

Get the content box to fill entire container?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Get the content box to fill entire container?

    I am trying to set up my vBulletin Blog, and the content box is not at the top of the container, nor does it go to the right hand side of the container... I have changed every setting I can think of, and cannot figure out what I am doing wrong.

    here is the blog http://www.freegracechurches.org/forum/blog.php?b=1 to see what I mean.

    I tried looking for other threads where this has been discussed, but couldn't find anything. I found this: http://www.vbulletin.com/forum/showthread.php?t=242346 but when I opened my includes/blog_init.php, it didn't have the same code at the bottom as in that thread. My blog_init.php has this:
    // overwrite the messagearea stylevar with the smaller messagearea_usercp stylevar
    $stylevar['messagewidth'] = $stylevar['messagewidth_blog'];
    /*======================================================================*\
    || ####################################################################
    || # Downloaded: 15:42, Tue Nov 20th 2007
    || # SVN: $Revision: 23824 $
    || ####################################################################
    \*======================================================================*/
    ?>

  • #2
    I found this:
    http://www.vbulletin.com/forum/proje...?issueid=23217

    and tried it, but still no change in my blog message width.

    The only thing I can figure at this point is that the blog is calling the CSS for my website blog at http://www.freegracechurches.org/ which uses a three column (2 sidebars) template. If so, how can I override this (or duplicate the right sidebar) for the vBulletin Blog?

    What I want is what we see at this vbulletin blog: http://forum.osnn.net/blog.php?
    Last edited by jeremyers1; Wed 28th Nov '07, 8:22pm.

    Comment


    • #3
      As suspected, the problem is in my header. I reverted to the standard vBulletin header, and the formatting problem on my blog disappeared.

      So what piece of code do I need to add into my header or remove from my header to make it work?

      Here is my header code:

      <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
      <html xmlns="http://www.w3.org/1999/xhtml">
      <head profile="http://gmpg.org/xfn/11">
      <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
      <title> Free Grace Churches</title>
      <meta name="generator" content="WordPress 2.3.1" /> <!-- leave this for stats -->
      <link rel="shortcut icon" type="image/x-icon" href="http://www.freegracechurches.org/wp-...10/favicon.ico" />
      <link rel="stylesheet" href="http://www.freegracechurches.org/wp-...m-10/style.css" type="text/css" media="screen" />
      <link rel="alternate" type="application/rss+xml" title="Free Grace Churches RSS Feed" href="http://www.freegracechurches.org/?feed=rss2" />
      <link rel="pingback" href="http://www.freegracechurches.org/xmlrpc.php" />
      <!--[if !IE]><!-->
      <link rel="stylesheet" href="http://www.freegracechurches.org/wp-...m-10/NONie.css" media="screen" />
      <!--<![endif]-->
      <link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.freegracechurches.org/xmlrpc.php?rsd" />
      <link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.freegracechurches.org/wp-...lwmanifest.xml" /> <link
      type="text/css" rel="stylesheet" href="http://www.freegracechurches.org/wp-...itComments.css" />
      </head>
      <body>
      <div id="container">
      <div id="header">
      <h2><a href="http://www.freegracechurches.org/">Free Grace Churches</a></h2>
      <h3>"Planting and Supporting Free Grace Churches"</h3>
      </div>
      <div id="menu">
      <ul>
      <li class="page_item"><a href="http://www.freegracechurches.org">Home</a></li>
      <!--TEST
      http://freegracechurches.org/
      http://freegracechurches.org/forum/index.php/
      --><li class="page_item page-item-8"><a href="http://www.freegracechurches.org/forum/index.php" title="Forums">Forums</a></li>
      <li class="page_item page-item-2"><a href="http://www.freegracechurches.org/about/" title="About">About</a></li>
      <li class="page_item page-item-10"><a href="http://www.freegracechurches.org/contact-us/" title="Contact Us">Contact Us</a></li>
      </ul>
      </div>
      <div id="middlepic"></div>

      <div id="left">
      <div id="lpic"></div>
      </div>
      <div id="right">
      <div id="rpic"></div>
      </div>

      <!-- content table -->
      $spacer_open
      $_phpinclude_output
      Just for comparison, here is the standard vBulletin header code:

      <!-- logo -->
      <a name="top"></a>
      <table border="0" width="$stylevar[outertablewidth]" cellpadding="0" cellspacing="0" align="center">
      <tr>
      <td align="$stylevar[left]"><a href="$vboptions[forumhome].php$session[sessionurl_q]"><img src="$stylevar[titleimage]" border="0" alt="$vboptions[bbtitle]" /></a></td>
      <td align="$stylevar[right]">
      &nbsp;
      </td>
      </tr>
      </table>
      <!-- /logo -->
      <!-- content table -->
      $spacer_open
      $_phpinclude_output

      Comment


      • #4
        As suspected, the problem is with my header. I reverted to the standard vBulletin header, and everything looks perfect now. So what do I need to add/remove from my header to make it usable?

        <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
        <html xmlns="http://www.w3.org/1999/xhtml">
        <head profile="http://gmpg.org/xfn/11">
        <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
        <title> Free Grace Churches</title>
        <meta name="generator" content="WordPress 2.3.1" /> <!-- leave this for stats -->
        <link rel="shortcut icon" type="image/x-icon" href="http://www.freegracechurches.org/wp-content/themes/ad-clerum-10/favicon.ico" />
        <link rel="stylesheet" href="http://www.freegracechurches.org/wp-content/themes/ad-clerum-10/style.css" type="text/css" media="screen" />
        <link rel="alternate" type="application/rss+xml" title="Free Grace Churches RSS Feed" href="http://www.freegracechurches.org/?feed=rss2" />
        <link rel="pingback" href="http://www.freegracechurches.org/xmlrpc.php" />
        <!--[if !IE]><!-->
        <link rel="stylesheet" href="http://www.freegracechurches.org/wp-content/themes/ad-clerum-10/NONie.css" media="screen" />
        <!--<![endif]-->
        <link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.freegracechurches.org/xmlrpc.php?rsd" />
        <link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.freegracechurches.org/wp-includes/wlwmanifest.xml" /> <link
        type="text/css" rel="stylesheet" href="http://www.freegracechurches.org/wp-content/plugins/wp-ajax-edit-comments/css/editComments.css" />
        </head>
        <body>
        <div id="container">
        <div id="header">
        <h2><a href="http://www.freegracechurches.org/">Free Grace Churches</a></h2>
        <h3>"Planting and Supporting Free Grace Churches"</h3>
        </div>
        <div id="menu">
        <ul>
        <li class="page_item"><a href="http://www.freegracechurches.org">Home</a></li>
        <!--TEST
        http://freegracechurches.org/
        http://freegracechurches.org/forum/index.php/
        --><li class="page_item page-item-8"><a href="http://www.freegracechurches.org/forum/index.php" title="Forums">Forums</a></li>
        <li class="page_item page-item-2"><a href="http://www.freegracechurches.org/about/" title="About">About</a></li>
        <li class="page_item page-item-10"><a href="http://www.freegracechurches.org/contact-us/" title="Contact Us">Contact Us</a></li>
        </ul>
        </div>
        <div id="middlepic"></div>

        <div id="left">
        <div id="lpic"></div>
        </div>
        <div id="right">
        <div id="rpic"></div>
        </div>

        <!-- content table -->
        $spacer_open
        $_phpinclude_output

        Comment


        • #5
          I figured it out on my own. i'm posting here just in case others have a similar problem later.

          First, I reverted the header to see if it was a problem with my custom header. It looked fine, so I knew I had found my problem.

          Then I went back to my custom header and removed the line pointing to my Stylesheet, and that fixed the main part of my problem, but since there was no stylesheet, introduced others. But now I knew that the problem was with my stylesheet.

          I figured it would probably be with the #container or #content and so focused on those first. With a little tweaking and a new stylesheet, I've got it fixed.

          Comment

          Related Topics

          Collapse

          Working...
          X