Announcement

Collapse
No announcement yet.

help

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • hawkbone
    replied
    smartFTP

    I just got smart FTP how would I connect it to my tripod account

    Leave a comment:


  • filburt1
    replied
    Oh dear god (after clicking the phpinfo URL).

    Anyway, in Notepad, type this:

    [code]
    <? phpinfo(); ?>
    [/code]
    Then when you save it, save it as "phpinfo.php", [b]including the quotes[/b]. Then upload it and post the URL here.

    Leave a comment:


  • hawkbone
    replied
    Frustrated!

    I tried it and when I go to [URL=http://http://members.lycos.co.uk/hotshot68/forums.html]http://members.lycos.co.uk/hotshot68/forums[/URL] it gets denied and yes tripod.co.uk says it has sum php4u whatever it is and it has mysql, I have no clue how to make things ascii or binary. Yes that is the full error message too.[url]http://members.lycos.co.uk/hotshot68/phpinfo.[/url]
    Last edited by hawkbone; Thu 18th Jul '02, 10:19am.

    Leave a comment:


  • Steve Machol
    replied
    Is that the exact and complete error message? Are you sure that your host has PHP installed?

    Try reuploaing the original db_mysql.php. Make sure you upload in ASCII and overwrite the one on the server.

    Also do you have a phpinfo.php file? If not create a text file with this content:

    [php]<?php
    phpinfo();
    ?>[/php]Name it 'phpinfo.php' then upload it to your forum directory and post the URL here. This will help us troubleshoot the problem.

    Leave a comment:


  • hawkbone
    replied
    yes I have I put in my tripod user name in the format it told me to and now I have put a password in that I have for my account but this keeps happening. As I said above does it matter if my config. pad says its a text format only?And my database is hotshot68_uk_db


    SQL-query : [Edit]

    <?php

    $db="mysql"


    MySQL said:


    You have an error in your SQL syntax near '<?php

    $db="mysql"' at line 1


    Back
    Last edited by hawkbone; Thu 18th Jul '02, 8:43am.

    Leave a comment:


  • Steve Machol
    replied
    Did you setup the database, user and password first? You need all three of these to make it work.

    Leave a comment:


  • hawkbone
    replied
    this is my config. so far I do have a cppassword that I made up and I put a user name in but it says that it's not required to put a password in dbpassword , also it said that my config is now a text format only, is that a problem?

    <?php



    $db="mysql";


    $servername="localhost";


    $dbusername="hotshot68";
    $dbpassword="";

    $dbname="hotshot68_uk_db";


    $cppassword="";

    ?>

    this is what tripod says

    The name of your MySQL database is automatically generated according to your Tripod ID. It has the following form: id_uk_db.

    If your id is paco14, the name of your database is paco14_uk_db.


    Database connection


    Tripod uses a simplified connection method for accessing your database. You do not need any special parameters to access your data. To connect to your MySQL database using a PHP script, use the following code:

    $db = mysql_connect()

    You can then use the database however you want and make the requests of your choice.

    The following apply if you need parameters:


    - database host: localhost


    - database access login: your Tripod id


    - database access password: empty


    - database name: id_uk_db


    This is my error message


    SQL-query : [Edit]

    <?php

    $db="mysql"


    MySQL said:


    You have an error in your SQL syntax near '<?php

    $db="mysql"' at line 1


    Back
    Last edited by hawkbone; Thu 18th Jul '02, 8:35am.

    Leave a comment:


  • Steve Machol
    replied
    Did you setup a database first along with a db username and password?

    Leave a comment:


  • hawkbone
    replied
    Also I uploaded all pics to site and now when I try to install (after clicking the link)this happens


    Make sure that you have filled in all the details in the config.php file. It should look something like this:

    <?
    // only mysql is supported at the moment
    $dbservertype="mysql";
    // hostname or ip of server
    $servername="localhost";
    // username and password to log onto db server
    $dbusername="root";
    $dbpassword="";
    // name of database
    $dbname="freeforum";

    //password for control panel
    $cppassword="foy4wellesley";
    ?>


    Also I uploaded all pics to site and now when I try to install (after clicking the link)this happens

    Leave a comment:


  • hawkbone
    started a topic help

    help

    this pops up after I do everything tripod says MySQL said:


    You have an error in your SQL syntax near '<?php

    $db= mysql_connect()

    $servername="localhost"' at line 1


    Back any help?
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X