Announcement

Collapse
No announcement yet.

lite version: mysql moving server problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts
    Loveless
    New Member

  • Loveless
    replied
    yes I fixed it.

    For anyone who also had this problem: CHMOD it to 444 first. ^^

    Leave a comment:

  • Loveless
    New Member

  • Loveless
    replied
    bash-2.04$ mysql -uUSER_pb -pPASSWORD DBNAME < /home/www/all-databases.sql
    bash: /home/www/all-databases.sql: Permission denied
    (why is it doing that when the username/pw/db is correct? so I run the below command)
    bash-2.04$ mysql -uUSER -pPASSWORD DBNAME
    Welcome to the MySQL monitor. Commands end with ; or \g.
    Your MySQL connection id is 430748 to server version: 3.23.45

    Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

    mysql> Aborted
    bash-2.04$

    as you can see, I can't add [b]< /home/www/all-databases.sql
    [/b] or it will say access denied O_o??

    Leave a comment:

  • Steve Machol
    Former Customer Support Manager

  • Steve Machol
    replied
    That's what I thought. This should be:

    mysql -umysqlusername -p databasename [b]<[/b] /path/to/sqlfile.sql

    By using > instead of < you are writing to the file instead of reading it.

    Leave a comment:

  • Loveless
    New Member

  • Loveless
    replied
    mysql -u[b]mysqlusername[/b] -p databasename > /path/to/sqlfile.sql

    yep yep

    the extracted sql file is about 14mb and as soon as I hit that, the sql file becomes 0byte O_o??

    I tried with different username and password paired with a new database and same thing occurs. :eek:

    Leave a comment:

  • Steve Machol
    Former Customer Support Manager

  • Steve Machol
    replied
    Restoring does not write to the sql file, it reads it. What command are you using to restore?

    Leave a comment:

  • Loveless
    New Member

  • Loveless
    started a topic lite version: mysql moving server problem

    lite version: mysql moving server problem

    I am trying to move my lite version of vB based on this link: [url]http://vbulletin.com/manual/movingservers.html[/url]

    I've done it before without a problem but today when I try to restore the database, instead of doing what it suppose to it made the sql file into 0byte. I did it over and over again yet the problem still persist.
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X