Announcement

Collapse
No announcement yet.

Install Error on step 3---again

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Install Error on step 3---again

    message i get on step 3:

    Attempting to connect...


    Fatal error: Call to unsupported or undefined function mysql_pconnect() in db_mysql.php3 on line 29

    now don't yell at me too much...i don't understand php at all. pleae help

  • #2
    open db_mysql.php and change
    mysql_pconnect();

    to:
    mysql_connect();

    Comment


    • #3
      Hmm

      I just did that, and now I get

      Fatal error: Call to unsupported or undefined function mysql_connect() in db_mysql.php on line 31

      Comment


      • #4
        I had exactly the same problem and found a hint in the Install forum to use

        [url]http://www.rpmfind.net/linux/RPM/mandrakecooker/contrib/RPMS/php-mysql-3.0.14-2mdk.i586.html[/url]

        I had all the other components of MySQL, PHP and vbLite installed, but not this critical link, which RedHat leaves out since they support PostgreSQL, not MySQL, with PHP.

        Peter E. Humphries
        Peter E. Humphries

        Comment


        • #5
          Ahh that will be it then...

          That link seems to be dead though :(

          Comment


          • #6
            The source code RPM link is dead, but click on what appears to be the title and you can download the binary RPM. I had a moment of consternation, myself. :)

            Or, just download it from this message, since I am such a thoughtful guy! :D

            [url]ftp://rpmfind.net/linux/MandrakeCooker/contrib/RPMS/php-mysql-3.0.14-2mdk.i586.rpm[/url]

            Peter E. Humphries

            [Edited by phumphries on 07-04-2000 at 01:50 PM]
            Peter E. Humphries

            Comment


            • #7
              Thanks for that.

              So to get this straight. I have Redhat 6.2, with all the included RPMS installed, so to get vBulletin working all I need to do is install an RPM for MySql,the vBulletin software, and the mandrake rpm for php ?.

              Actually as Redhat 6.2 includes php 3, would it be better to install an RPM for php 4 ?.

              Séan

              Comment


              • #8
                Well, here is what I did:[list=1][*] Install RedHat 6.2 with Apache and PHP (I used the Custom option and ensured that everything I wanted was selected by checking the Individual Modules box)[*] Install MySQL[*] Install Perl updates[*] Install PHP modules for MySQL[/list=1]
                I just used the PHP3 included with RedHat 6.2. I installed the perl modules because of dependencies. And, one of the MySQL files needs [b]--nodep[/b] because of a case sensitivity problem.

                The MySQL RPMs that I used are:[list][*] [URL="http://www.mysql.com/Downloads/MySQL-3.22/MySQL-shared-3.22.32-1.i386.rpm"]MySQL-shared-3.22.32-1.i386.rpm[/URL][*] [URL="http://www.mysql.com/Downloads/MySQL-3.22/MySQL-bench-3.22.32-1.i386.rpm"]MySQL-bench-3.22.32-1.i386.rpm[/URL][*] [URL="http://www.mysql.com/Downloads/MySQL-3.22/MySQL-client-3.22.32-1.i386.rpm"]MySQL-client-3.22.32-1.i386.rpm[/URL][*] [URL="ftp://ftp.redhat.com/pub/contrib/libc6/i386/mysql-DBI-perl-bin-1.825-1.i386.rpm"]mysql-DBI-perl-bin-1.825-1.i386.rpm[/URL][*] [URL="http://www.mysql.com/Downloads/MySQL-3.22/MySQL-devel-3.22.32-1.i386.rpm"]MySQL-devel-3.22.32-1.i386.rpm[/URL][*] [URL="http://www.mysql.com/Downloads/MySQL-3.22/MySQL-3.22.32-1.i386.rpm"]MySQL-3.22.32-1.i386.rpm[/URL][/list]
                The Perl RPMs that I used are:[list][*] [URL="ftp://ftp.redhat.com/pub/contrib/libc6/i386/DBI-perl-bin-0.93-1.i386.rpm"]DBI-perl-bin-0.93-1.i386.rpm[/URL][/list]
                The PHP RPMs that I used are:[list][*] [URL="ftp://rpmfind.net/linux/MandrakeCooker/contrib/RPMS/php-mysql-3.0.14-2mdk.i586.rpm"]php-mysql-3.0.14-2mdk.i586.rpm[/URL][/list]
                If they are not already installed, you will need perl-5.00503-10 and apache-1.3.12-2, both on CD-1 of the RedHat package.

                The commands and their order are:[list][*] rpm -Uvh MySQL-3.22.32-1.i386.rpm[*] rpm -Uvh MySQL-client-3.22.32-1.i386.rpm[*] /usr/bin/mysqladmin -u root password 'yournewpassord'[*] rpm -Uvh MySQL-devel-3.22.32-1.i386.rpm[*] rpm -Uvh MySQL-shared-3.22.32-1.i386.rpm[*] rpm -Uvh DBI-perl-bin-0.93-1.i386.rpm[*] rpm -Uvh mysql-DBI-perl-bin-1.825-1.i386.rpm[*] rpm -Uvh --nodeps MySQL-bench-3.22.32-1.i386.rpm[*] rpm -Uvh php-mysql-3.0.14-2mdk.i586.rpm[/list]
                It is advisable to test your MySQL installation, too. You can find excellent instructions in the [URL="http://www.mysql.com/documentation/mysql/commented/manual.php?section=Post-installation"]MySQL Documentation[/URL]; skip down to step 3 and use the command format [b]/usr/bin/mysqladmin -p version[/b] so that you will be prompted for your root password.

                You will also have to modify [b]/etc/httpd/conf/httpd.conf[/b]. The line

                [Code]AddType application/x-httpd-php3 .php3[/Code]

                should be modified to read

                [Code]AddType application/x-httpd-php3 .php3 .php[/Code]

                and the line

                [Code]DirectoryIndex index.html index.htm index.shtml index.cgi[/Code]

                should be modified to read

                [Code]DirectoryIndex index.php index.html index.htm index.shtml index.cgi[/Code]

                Reboot and follow the [i]vBulletin[/i] installation instructions. Happy messaging!

                Peter E. Humphries

                [Edited by phumphries on 07-05-2000 at 02:05 PM]
                Peter E. Humphries

                Comment


                • #9
                  Peter,

                  Your an absolute gent, I can't thank you enough for that !.

                  With a bit of luck and effort, I should be able to consign Lotus Domino to the bin !.

                  Chears !

                  Sean

                  Comment


                  • #10
                    Thank you.

                    Maybe you can help me with something (or at least take warning!). If I use [b]linuxconf[/b] to modify my Apache settings, I am suddenly presented with [i][b]Forbidden[/b][/i] errors when browsing to my machine, even using Lynx from the same machine to access [i]Localhost[/i].

                    I have put in a service request with RedHat, but I wonder if anyone else has experienced this. I have tried many fresh installations and have narrowed it down to a problem with [b]linuxconf[/b], even just adding directives for the log files.

                    Peter E. Humphries
                    Peter E. Humphries

                    Comment


                    • #11
                      I STRONGLY urge you to NOT use linuxconf. In my experience it messes up a variety of different services. If it sees anything that it doesn't like it changes it, if it is expecting a different version of a program it causes problems, etc...
                      Interested in Linux?
                      Have a question?
                      http://www.linuxquestions.org

                      Comment


                      • #12
                        Thanks for the information. I did a bunch of other configuration with [b]linuxconf[/b] but did not touch the [i]Apache[/i] module and all seems well.

                        One other note for the installation steps, above: change the line (in [b]/etc/httpd/conf/httpd.conf[/b])

                        [Code]AddType application/x-httpd-php3 .php3[/Code]

                        to read

                        [Code]AddType application/x-httpd-php3 .php3 .php[/Code]

                        That way, you do not have to worry about compatibility between php/fi and php3 files (PHP3 can handle both).

                        Peter E. Humphries

                        [Edited by phumphries on 07-05-2000 at 02:26 PM]
                        Peter E. Humphries

                        Comment

                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                        Working...
                        X