Announcement

Collapse
No announcement yet.

Warning: curl_setopt() [function.curl-setopt]: Invalid curl configuration option

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Warning: curl_setopt() [function.curl-setopt]: Invalid curl configuration option

    After my ISP changhe the PHP to 5.2.1.4 the subscription manager don't update the user to the right group...

    VB version 3.6.12

    in the test comunication I've this problem:

    Code:
    Warning: curl_setopt() [function.curl-setopt]:  Invalid curl configuration option in /includes/paymentapi/class_paypal.php  on line 182
    Can you help me?

  • #2
    You or your host will need to recompile PHP with full cURL support.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Have you rechecked all your configuration options? And, when you upgraded the php, did you check to make sure cURL support is enabled?

      Please don't PM or VM me for support - I only help out in the threads.
      vBulletin Manual & vBulletin 4.0 Code Documentation (API)
      Want help modifying your vbulletin forum? Head on over to vbulletin.org
      If I post CSS and you don't know where it goes, throw it into the additional.css template.

      W3Schools <- awesome site for html/css help

      Comment


      • #4
        this is the PHP info() relative...

        PHP Version 5.2.14

        System Linux ****.****.com 2.6.33.4-5 #1 SMP Fri May 14 10:58:19 UTC 2010 i686
        Build Date Aug 13 2010 02:05:00
        Configure Command './configure' '--prefix=/usr' '--enable-cli' '--enable-cgi' '--enable-fastcgi' '--enable-zend-multibyte' '--enable-bcmath' '--enable-json' '--with-bz2' '--enable-calendar' '--with-curl' '--enable-dbase' '--enable-exif' '--enable-ftp' '--with-gettext' '--with-gmp' '--with-iconv' '--enable-mbstring' '--with-mcrypt' '--enable-memory-limit' '--with-mhash' '--enable-hash' '--with-ming' '--with-ncurses' '--with-openssl' '--with-pspell' '--enable-shmop' '--enable-sockets' '--enable-sysvmsg' '--enable-sysvsem' '--enable-sysvshm' '--enable-wddx' '--with-xmlrpc' '--with-zlib' '--disable-debug' '--enable-dba' '--with-cdb' '--with-db4' '--with-flatfile' '--with-gdbm' '--with-inifile' '--enable-dbx' '--with-freetype-dir=/usr' '--with-t1lib' '--enable-gd-native-ttf' '--with-jpeg-dir=/usr' '--with-png' '--with-gd' '--with-imap=shared' '--with-unixODBC=shared,/usr' '--with-readline' '--with-xsl=shared' '--enable-sqlite-utf8' '--enable-soap=shared' '--enable-pdo=shared' '--with-sqlite=shared' '--with-pdo-sqlite=shared' '--with-pdo-mysql=shared' '--with-pdo-pgsql=shared' '--with-mysql=shared' '--with-mysqli=shared' '--with-pgsql=shared' '--with-ldap=shared' '--enable-mbstr-enc-trans' '--enable-mbregex' '--enable-magic-quotes' '--enable-discard-path' '--with-pear' '--enable-safe-mode' '--enable-track-vars' '--with-ttf' '--enable-zip=shared' '--enable-hts=shared' '--enable-htscanner=shared' '--enable-adodb=shared' '--enable-ew=shared' '--enable-ea=shared' '--with-imagick=shared' '--with-pdflib=shared' '--with-fdftk=shared' '--with-tidy=shared' '--with-config-file-scan-dir=_custom_php_settings'

        Server API CGI/FastCGI

        Virtual Directory Support

        curl
        cURL support enabled
        cURL Information libcurl/7.15.5 OpenSSL/0.9.8b zlib/1.2.3 libidn/0.6.5

        Comment


        • #5
          Then is you are still getting that error there is something wrong with that cURL module. Here is what mine shows:

          curl
          cURL support enabled
          cURL Information 7.21.0
          Age 3
          Features
          AsynchDNS No
          Debug No
          GSS-Negotiate No
          IDN Yes
          IPv6 No
          Largefile Yes
          NTLM Yes
          SPNEGO No
          SSL Yes
          SSPI No
          krb4 No
          libz Yes
          CharConv No
          Protocols dict, file, ftp, ftps, http, https, imap, imaps, ldap, ldaps, pop3, pop3s, rtsp, smtp, smtps, telnet, tftp
          Host i686-pc-linux-gnu
          SSL Version OpenSSL/0.9.7a
          ZLib Version 1.2.1.2
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment

          Related Topics

          Collapse

          Working...
          X