Pretty simple question really. I have been running 3.7 and I recently was hacked. I am not sure if this is because of my poor host (which I later found out has had happened to many people), or if it was because I was running version 3.7.

So my question to you staff is, is there a way to keep running 3.7 securly? If I install the latest version of 3.7 and have a secure host, will I be good to go?