Announcement

Collapse
No announcement yet.

PayPal Instant Payment Notification Warning?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mike Robinson
    replied
    Originally posted by Trevor Hannant View Post
    We're not aware of what has changed to cause this at the moment so if we can look directly at the problem...
    I stress this is not a new problem. Looking back through the logs it has been happening ever since I activated a subscription system about a year ago. What is new is that Paypal has just recently implemented a policy of sending out IPN failure warnings and apparently it is a case of 5 warnings and you're out.

    Fortunately I have not had any further warnings in the last few days as the only donation we had in the last week or so seemed to have gone through without any problem. But then some of the previous transactions over the last year have gone through without a problem also. More often than not though, each transaction (including payments into the Paypal account which are not forum subscriptions) is followed by 16 IPN failures.

    Leave a comment:


  • Zachery
    replied
    Thanks, I'll make sure a developer sees this and we'll see what we can do on our end.

    Leave a comment:


  • gpzzone
    replied
    Further reading suggests that the problem may be allied to a Paypal account that is used by a number of different sources, and that the IPN message is being sent to the wrong url, hence the bounce.

    I'm sorry I offer no solutions, just food for thought, I lack the know how to solve problems, but I can help to identify their source.

    My money is on either a port setting issue, or a problem with Paypal sending IPN messages to the wrong urls as a consequence of it (Paypal account) being accessed by numerous sources.

    Leave a comment:


  • gpzzone
    replied
    It appears that the Actinic (E-commerce) community are experiencing a similar problem, with orders that are "pending Paypal Payment" not being released for processing becasue the IPN system is failing them.

    As always it's a nightmare to determine where the problem lies when there is such a lot of integration between software writers. Apparently Paypal implemented the change on 01/01/10, and that's when it all started.

    I am not a developer, soi don't fully understand the why's and wherefore's, but someone, somewhere might............and help us all resolve the issue.

    But the Actinic guru's (have investigated it) and believe that the problem may lie with the port settings....

    Forgive me for posting if it's a problem, but I feel that this information may help VB developers resolve the issue, after all we have to accept that we'll never get anywhere with Paypal...

    With grateful thanks to Zoltan at the Actinic.......

    ...... According to Paypal nothing has changed as usual. However checking the possible reasons it looks like they have changed their system and now callbacks to Paypal servers are not allowed on port 80. Pre v8 versions are using that port but v8 and newer uses https at port 443. This is the reason why only versions earlier than v8 are broken.

    As far as I can see the function needed for the https communication is already in the v7 scripts. Therefore it can be fixed by a simple script change. Just locate PostPayPal.fil in the CommonOCC folder within your site folder. Then open it in a plain text editor and find the lines

    Code:
    ($status, $sError, $sHttpStatus, $sResponse) = ACTINIC::HTTP_SendAndReceive('www.paypal.com', 80,
    '/cgi-bin/webscr', $sPostedData, 'POST');
    This needs to be changed to have
    Code:
    ($status, $sError, $sHttpStatus, $sResponse) = ACTINIC::HTTPS_SendAndReceive('www.paypal.com', 443, '/cgi-bin/webscr', $sPostedData, 'POST');
    Once the file is edited and saved do a web refresh and Paypal should be working again.

    I hope this helps.
    __________________
    Zoltan
    Actinic Software
    www.actinic.co.uk

    Leave a comment:


  • Trevor Hannant
    replied
    Can someone who's having these issues please raise a support ticket and link back to this thread. Please also provide the following details in the 'Sensitive Data' box please:

    - AdminCP login details
    - FTP login details

    We're not aware of what has changed to cause this at the moment so if we can look directly at the problem...

    Leave a comment:


  • vitrag24
    replied
    Originally posted by cbiweb View Post
    Here is what I did, based on a post by BBR-APBT earlier in this thread. Keep in mind this thread is in the 3.7 forum, and I only have 3.8.4 and 4.0.1 installed, so the template information may not be exactly the same but it should be close enough to work with:

    Go to your subscription_payment_paypal template found in the 'Subscriptions (Paid) Templates' group.
    In 3.8.x (and 3.7?) look for:
    Code:
    <input type="hidden" name="notify_url" value="$vboptions[bburl]/payment_gateway.php?method=paypal" />
    In 4.0.x look for:
    Code:
    <input type="hidden" name="notify_url" value="{vb:raw vboptions.bburl}/payment_gateway.php?method=paypal" />
    Notice the payment_gateway.php?method=paypal part of the code? You need to make sure your Notification URL contains that code.
    To do so, log into your PayPal account and go to Profile > Instant Payment Notification Preferences.
    The Notification URL should be something like this http://www.yoursitename.com/forums/payment_gateway.php?method=paypal

    Once I edited mine to look like that, the emails stopped.
    http://www.yoursite.com/payment_gate...?method=paypal

    I think this is the correct link.. there should not /forums after domain.com
    as in previous successful as well as failed and retries, it's showing this url in ipn history.

    Why vbulletin team isn't answering this query?

    Leave a comment:


  • dm_fan
    replied
    We have started getting these emails from paypal as well.

    I our case, we have a subscription setup in vB that you can pay for with paypal. Plus we also have a number of items listed on ebay which people use paypal to purchase.

    I've looked at the subscription logs in vB and at the IPN log in our paypal account. They both show that anytime any payment is made to our paypal account, paypal's IPN system is trying to send the notification to our vB server. If the payment is for our vB subscription, it gets validated right away (just like it should). If it's a non-subscription payment, the IPN fails because vB doesn't see a valid subscription. So paypal trys to sent the notification again and again and again, with the same failed result. Apparently this has been going on for years because I have a log full of failures going back to when we began the subscription option on our forums.

    So in my case, I think I need to either:
    - tell paypal to only send those notifications on subscription payments that originate from our forums API access.
    - or get our vB forums to return a "valid" message to paypal when a non-subscription IPN is recieved.

    Does anyone know how to do either of these?

    Steve

    Leave a comment:


  • cbiweb
    replied
    Originally posted by vitrag24 View Post
    @cbiweb,

    I've checked my templates, they are same as you've pasted.

    Still i've got another similar email today..
    Yes, it will be in the templates; I put that in my post just to show where I'm getting the URL from. So did you check the URL in your PayPal account per my instructions? You should see a button for editing your IPN settings. Also, why not simply turn on IPN as it said in your PayPal history?


    @sross: I haven't gotten an email in two days, so it either works or the PP system gave up. The real test will come if/when someone donates to my site again.

    Leave a comment:


  • Zachery
    replied
    Upi need to turn IPN on.

    Leave a comment:


  • vitrag24
    replied
    @cbiweb,

    I've checked my templates, they are same as you've pasted.

    Still i've got another similar email today..

    -------------
    in paypal-history-ipn history-- it's showing "The IPN feature is turned off. You must turn on IPN in order to create history data."

    shd i do something?

    Please check and help me..

    @Vbulletin Team, we need your advice..

    Leave a comment:


  • sross
    replied
    I hope your fix works, however my paypal alert seems to stop for a day then start up again, can you post back tomorrow with another "all clear"? Thanks!

    *well I've gone ahead and made the change, will post an update tomorrow
    Last edited by sross; Mon 8th Feb '10, 12:48pm.

    Leave a comment:


  • cbiweb
    replied
    Here is what I did, based on a post by BBR-APBT earlier in this thread. Keep in mind this thread is in the 3.7 forum, and I only have 3.8.4 and 4.0.1 installed, so the template information may not be exactly the same but it should be close enough to work with:

    Go to your subscription_payment_paypal template found in the 'Subscriptions (Paid) Templates' group.
    In 3.8.x (and 3.7?) look for:
    Code:
    <input type="hidden" name="notify_url" value="$vboptions[bburl]/payment_gateway.php?method=paypal" />
    In 4.0.x look for:
    Code:
    <input type="hidden" name="notify_url" value="{vb:raw vboptions.bburl}/payment_gateway.php?method=paypal" />
    Notice the payment_gateway.php?method=paypal part of the code? You need to make sure your Notification URL contains that code.
    To do so, log into your PayPal account and go to Profile > Instant Payment Notification Preferences.
    The Notification URL should be something like this http://www.yoursitename.com/forums/payment_gateway.php?method=paypal

    Once I edited mine to look like that, the emails stopped.

    Leave a comment:


  • sross
    replied
    still getting them.. I don't understand what paypal will do? Are they going to ban our accounts?

    Leave a comment:


  • vitrag24
    replied
    Where is vbulletin support team?

    I hope they will look into matter and provide solution.

    Leave a comment:


  • ricker
    replied
    I am having the same issue...

    Leave a comment:

widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X