Announcement

Collapse
No announcement yet.

Private.php Hangs on PM Send

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Private.php Hangs on PM Send

    Just moved a forum to a new server and I'm having issues with sending PMs and the PM Data Manager...

    I've debugged down to private.php:

    Code:
    // everything's good!
      $pmdm->save();
    This line hangs the entire process up. Any ideas what would cause the data manager to hang (and eventually timeout)? Logs show nothing.
    Ted & the Giftery.me Team

    New features released for Product Review Forums 1.3 (4.0)
    Helpful Answers (3.8) (4.0) | Limited Guest Viewing (3.8) (4.0)

  • #2
    Try disabling your modifications/plugins and see if you still have this problem. It could be a mod that is causing the problem there.
    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

    PHP Code:
    define('DISABLE_HOOKS'true); 

    Please don't PM or VM me for support - I only help out in the threads.
    vBulletin Manual & vBulletin 4.0 Code Documentation (API)
    Want help modifying your vbulletin forum? Head on over to vbulletin.org
    If I post CSS and you don't know where it goes, throw it into the additional.css template.

    W3Schools &lt;- awesome site for html/css help

    Comment


    • #3
      Thank you Lynne but unfortunately disabling plugins did not resolve the issue.
      Ted & the Giftery.me Team

      New features released for Product Review Forums 1.3 (4.0)
      Helpful Answers (3.8) (4.0) | Limited Guest Viewing (3.8) (4.0)

      Comment


      • #4
        What error do you get?

        Comment


        • #5
          None. The script simply hangs until Apache eventually times out.
          Ted & the Giftery.me Team

          New features released for Product Review Forums 1.3 (4.0)
          Helpful Answers (3.8) (4.0) | Limited Guest Viewing (3.8) (4.0)

          Comment


          • #6
            Hmmm, then try this:
            Create a new style with no parent:
            • Styles & Templates > Style Manager > Add New Style
            • Parent Style: No Parent Style
            • Title: Default vBulletin
            • Allow User Selection: Yes
            • Save


            Then browse the site using that totally default vbulletin style - do you still have the same problem?


            But also, take a look at your error_logs (if you don't know where they are, ask your host) as there may be more information about this in there.

            Please don't PM or VM me for support - I only help out in the threads.
            vBulletin Manual & vBulletin 4.0 Code Documentation (API)
            Want help modifying your vbulletin forum? Head on over to vbulletin.org
            If I post CSS and you don't know where it goes, throw it into the additional.css template.

            W3Schools &lt;- awesome site for html/css help

            Comment


            • #7
              Thanks again Lynne.

              Did a complete upgrade to 3.8.4 current, setup a new style and no luck.

              Also no luck with the error log -- it shows nothing (log level set to error).
              Ted & the Giftery.me Team

              New features released for Product Review Forums 1.3 (4.0)
              Helpful Answers (3.8) (4.0) | Limited Guest Viewing (3.8) (4.0)

              Comment


              • #8
                Then you should start a support ticket!

                Comment


                • #9
                  Nothing in your error_log? Wow. Usually there is something in there from some wrong link someone clicks.

                  If you are turned off plugins and are using a default style, the only other thing I can think of is to make sure you upload all default files.

                  Also, check maintenance > diagnostics > problematic webserver modules. Does anything show up there?

                  Please don't PM or VM me for support - I only help out in the threads.
                  vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                  Want help modifying your vbulletin forum? Head on over to vbulletin.org
                  If I post CSS and you don't know where it goes, throw it into the additional.css template.

                  W3Schools &lt;- awesome site for html/css help

                  Comment


                  • #10
                    Originally posted by Lynne View Post
                    Nothing in your error_log? Wow. Usually there is something in there from some wrong link someone clicks.

                    If you are turned off plugins and are using a default style, the only other thing I can think of is to make sure you upload all default files.

                    Also, check maintenance > diagnostics > problematic webserver modules. Does anything show up there?

                    Nope! Just to be sure it wasn't the files I did a clean file install and nothing. I'm thinking this may be a server issue that I'll have to dig into. Any idea how the data store actually stores PMs so I know where to look?
                    Ted & the Giftery.me Team

                    New features released for Product Review Forums 1.3 (4.0)
                    Helpful Answers (3.8) (4.0) | Limited Guest Viewing (3.8) (4.0)

                    Comment


                    • #11
                      One additional fact, PMs are making it to the user so the script is geting that far before timing out.
                      Ted & the Giftery.me Team

                      New features released for Product Review Forums 1.3 (4.0)
                      Helpful Answers (3.8) (4.0) | Limited Guest Viewing (3.8) (4.0)

                      Comment


                      • #12
                        You can try looking in includes/class_dm_pm.php . But, also do that diagnotics test I mentioned. I don't know that anything will show up, but who knows.

                        Please don't PM or VM me for support - I only help out in the threads.
                        vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                        Want help modifying your vbulletin forum? Head on over to vbulletin.org
                        If I post CSS and you don't know where it goes, throw it into the additional.css template.

                        W3Schools &lt;- awesome site for html/css help

                        Comment


                        • #13
                          I gave it a shot, no luck (everything was no).

                          Playing with the source code now. Thanks
                          Ted & the Giftery.me Team

                          New features released for Product Review Forums 1.3 (4.0)
                          Helpful Answers (3.8) (4.0) | Limited Guest Viewing (3.8) (4.0)

                          Comment

                          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                          Working...
                          X