Announcement

Collapse
No announcement yet.

help please

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • help please

    database error:
    PHP Code:
     Database error in vBulletin 3.8.4:

    Invalid SQL:

                
    SELECT fieldnamevarnametext
                FROM phrase
                WHERE languageid IN
    (-1,0) AND
                    
    fieldname IN ();

    MySQL Error   You have an error in your SQL syntaxcheck the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 4
    Error Number  
    1064
    Request Date  
    MondaySeptember 7th 2009 07:02:46 PM
    Error Date    
    MondaySeptember 7th 2009 07:02:47 PM
    Script        

    Referrer      
    IP Address    88.237.29.74
    Username      

    Classname     vB_Database
    MySQL Version 
    5.0.81-community 

  • #2
    SQL Syntax errors are almost always related to modified code.

    To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all plugins.

    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

    define('DISABLE_HOOKS', true);

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

    Do you have the same problem?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      not:S
      look attachments
      Attached Files

      Comment


      • #4
        Please follow the instruction I gave.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment

        Loading...
        Working...
        X