Announcement

Collapse
No announcement yet.

You may not delete/move this user - The user is either: (But they're NOT!)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • baghdad4ever
    replied
    if you dont want to enter phpmyadmin to know moderator id

    you can use this

    Code:
    DELETE FROM `moderator` WHERE `moderator`.`userid` =x LIMIT 1 ;

    where x is

    id number of the moderator must be removed


    take backup before you run this query

    Leave a comment:


  • cbiweb
    replied
    I have the same problem. Strangely, it involves three members, just like with GearTripper's issue. All, and I mean ALL settings have been checked (and I do know where all the settings are), and all the various troubleshooting already discussed has been tried.

    A big THANK YOU to GearTripper for figuring out which queries to run, as I was going ask that very thing. And like him, I do wonder what caused this to happen.

    Leave a comment:


  • OhioScions.com
    replied
    Thanks for this thread.

    It fixed my existing problem as well.

    I didn't know their mod id #, so I changed it to reflect this:

    DELETE FROM `moderator` WHERE `moderator`.`userid` =XX LIMIT 1

    Leave a comment:


  • baghdad4ever
    replied
    Originally posted by Zachery View Post
    USergroups do not make a person a moderator normally, you need to make sure they're not listed as a moderator.

    AdminCP > Forums & Moderators > Show All Moderators.

    yes they r not listed in the Show All Moderators list

    but i still cant prune or remove them

    and i edit the members now and i see

    they r in the registered usergroup

    Leave a comment:


  • Zachery
    replied
    USergroups do not make a person a moderator normally, you need to make sure they're not listed as a moderator.

    AdminCP > Forums & Moderators > Show All Moderators.

    Leave a comment:


  • baghdad4ever
    replied
    i make them moderator in the past with certain permission

    and then i transfere them to registered user group and remove it from REMOVE button

    but when i prune the user

    i cant

    Leave a comment:


  • GearTripper
    replied
    Originally posted by Wayne Luke View Post
    You assigned the people as moderators in the Forum Manager and never removed them as Moderators. Moderator permissions have nothing to do with Usergroup permissions and are stored separately.

    In fact the Moderator usergroup imparts no special permissions on its own and has the same basic permissions as the Registered Usergroup by default. It was only added because people wanted a usergroup for their moderators for whatever reason.
    So when I selected the REMOVE button next to "If You Would Like to Remove this Moderator", I wasn't really removing them as Moderators? C'mon man, I know better then that! In any case, my particular issue was fixed as noted above. Don't always assume your users don't know what they're doing. The problem was obviously an issue with vB somewhere along the line.

    Leave a comment:


  • Wayne Luke
    replied
    Originally posted by GearTripper View Post
    has removed the entries and fixed the problem. Still a bit curious as to what caused this though.
    You assigned the people as moderators in the Forum Manager and never removed them as Moderators. Moderator permissions have nothing to do with Usergroup permissions and are stored separately.

    In fact the Moderator usergroup imparts no special permissions on its own and has the same basic permissions as the Registered Usergroup by default. It was only added because people wanted a usergroup for their moderators for whatever reason.

    Leave a comment:


  • Zachery
    replied
    Did you ever add these users to a forum as moderators?

    Leave a comment:


  • baghdad4ever
    replied
    i have the same

    Leave a comment:


  • GearTripper
    replied
    Running the following SQL query:
    DELETE FROM `moderator` WHERE `moderator`.`moderatorid` =2 LIMIT 1 ;
    DELETE FROM `moderator` WHERE `moderator`.`moderatorid` =4 LIMIT 1 ;
    DELETE FROM `moderator` WHERE `moderator`.`moderatorid` =5 LIMIT 1 ;
    DELETE FROM `moderator` WHERE `moderator`.`moderatorid` =6 LIMIT 1 ;

    has removed the entries and fixed the problem. Still a bit curious as to what caused this though.

    Leave a comment:


  • GearTripper
    replied
    Speaking of the DB...

    In the Moderator table;

    Full Texts moderatorid userid forumid permissions importmoderatorid permissions2
    Edit Delete 1 1 -1 8339455 0 131071
    Edit Delete 2 38 -1 8207871 0 113659
    Edit Delete 4 22 -1 8207871 0 113659
    Edit Delete 5 279 -1 8207871 0 113659
    Edit Delete 6 4 -1 8207871 0 113659

    All userid's (38,22,279,4) sans myself (1) are no longer Moderators and the current Moderators are not listed here. What is this table referring to?

    Leave a comment:


  • Steve Machol
    replied
    I cannot duplicate this on an unmodified vB test forum so without any further info I would have to say a modification is causing this.

    Note: Just because you disabled or removed add-on does not remove the changes they made to the database.

    Leave a comment:


  • GearTripper
    replied
    Originally posted by Steve Machol View Post
    What is the usergroupid if the group that user is in? Do you have any third-party add-ons installed?
    Various usergroupid's; tried with several with same results. Disabled products/plugins, same results. I cannot reproduce this with any other userid except for these three former Moderators that used to be Moderators over a year ago. Not a huge issue, but it's there. Thought maybe something might be tagging along somewhere in the DB attached to the userid.

    Leave a comment:


  • Steve Machol
    replied
    What is the usergroupid if the group that user is in? Do you have any third-party add-ons installed?

    Leave a comment:

Related Topics

Collapse

Working...
X