Announcement

Collapse
No announcement yet.

SMTP error upon almost every post

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • SMTP error upon almost every post

    Right after switching servers, I get this error 99 out of every 100 posts or so:
    Warning: fsockopen() [function.fsockopen]: unable to connect to tls://smtp.gmail.com:465 (Connection timed out) in /includes/class_mail.php on line 604

    Also, only two "new post email notifications" have ever made it through. The vast majority of new post email notifications never leave the server.

    I've logged into gmail and looked and the 'sent box' has only 2 emails from the forums in all of March. Because there's at least 2 that managed to send, and because I cut-n-pasted the password from the vbulletin settings just to be sure it was all correct, I know the gmail login info is accurate in my settings.

    Thoughts?

  • #2
    It is possible that a bug in php versions lower than 4.3 could cause this error
    Simple Straight Forward EU cPanel vBulletin Web Hosting Provider.

    Comment


    • #3
      This is a connection issue between your server and smtp.gmail.com. You need to contact your host about this.
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #4
        Originally posted by Steve Machol View Post
        This is a connection issue between your server and smtp.gmail.com. You need to contact your host about this.
        Thanks, Steve. What aspect of the server should I bring to their attention? That is, what service is the vbulletin script calling upon, trying to worm its way through, or otherwise travel across to reach gmail?

        Comment


        • #5
          You have specifically set vB to use that SMTP server. That is not the default vB email setting. The server you are on cannot connect to that server. Therefore this is something you need to bring to the attention of your host.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            Originally posted by Steve Machol View Post
            You have specifically set vB to use that SMTP server. That is not the default vB email setting. The server you are on cannot connect to that server. Therefore this is something you need to bring to the attention of your host.
            Hmm. I guess what I'm asking is what 'channel', 'port', 'web service' or server aspect did you guys program vbulletin to use for externally connecting to an SMTP server? In other words, what do I ask my host to change for me that's currently blocking this? They will have no idea where to go or what to change since they didn't write vbulletin's external SMTP module, right?

            Comment


            • #7
              The only thing we use it what you set for the SMTP settings here:

              Admin CP -> vBulletin Options -> Email Options

              Again, this is not a vB issue. It's a server one.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X