Announcement

Collapse
No announcement yet.

Tried an SSH backup for the first time...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Tried an SSH backup for the first time...

    and now I have a constant Database Error.

    What the heck did I do wrong? How do I fix this????

    I used the command

    mysqldump --user [username] --password=[password] [databasename] > backup.sql

    I tried inputting
    mysql --user [username] --password=[password] [databasename] < backup.sql

    but to no avail.

    Help!!!!

  • #2
    This is one perfect command to get a gzipped backup.

    mysqldump --opt -Q -u USERNAME -p DATABASENAME | gzip > /home/username/dbbackup.sql.gz
    - This is the same USERNAME and DATABASENAME that you have entered in config.php
    - You'll be prompted for a password, enter the password that you have in config.php for your username.

    Comment


    • #3
      Originally posted by veenuisthebest View Post
      This is one perfect command to get a gzipped backup.

      - This is the same USERNAME and DATABASENAME that you have entered in config.php
      - You'll be prompted for a password, enter the password that you have in config.php for your username.
      If I do this now, will it get my site back up or is it gone forever?

      Comment


      • #4
        Why are you trying to restore a backup?

        We need to see the real error message. Right-click on the error page and go to View/Source. Then copy-n-paste the error message here.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          I was trying to back it up. I was hoping maybe reversing the command and restoring would fix it.

          It's the generic database error page

          Database error

          The database has encountered a problem.

          Please try the following:
          • Load the page again by clicking the Refresh button in your web browser.
          • Open the www.armywivesforums.com home page, then try to open another page.
          • Click the Back button to try another link.

          The www.armywivesforums.com forum technical staff have been notified of the error, though you may contact them if the problem persists.
          We apologise for any inconvenience.
          (or http://www.armywivesforums.com/forums will show it to you exactly.)

          Thank you for your help...

          Comment


          • #6
            For future reference, right-click on the error page and go to View/Source. That will show the real database error message:

            mysql_connect() [&lt;a href='function.mysql-connect'&gt;function.mysql-connect&lt;/a&gt;]: Access denied for user 'armyw3_admin'@'localhost' (using password: YES)
            /var/www/vhosts/armywivesforums.com/httpdocs/forums/includes/class_core.php on line 311

            The most likely cause of this error is that the info in your config.php file is wrong or your db user does not have full permissions to this database. Please read this for all the known causes of this error:

            http://www.vbulletin.com/forum/showthread.php?t=194542
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Thank you so much.

              I changed the password of the admin user for mysql without ever thinking of how that affected the forums

              I really appreciate the help and I'm sorry I didn't understand the View/Source thing

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X