Announcement

Collapse
No announcement yet.

maxloggedin error on edit post

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • stardotstar
    replied
    Sorry for necromancing this thread but I have just come to it when searching for the exact same error, about which there seems to be no clear understanding: vbulletin error when trying to edit a post (either inline or go advanced) 1. maxloggedin I had been working on some board optimisation and only just enabled the memcache section of the config.php. I began disabling products and so on but in the end found that the problem is caused by the config.php in which I enabled all the memcache settings. Now, my memcache appears to be running properly on the server; and I activated it purely with defaults (ports and so forth appear to be default so that seemed fine) but for the fact that I added a prefix intending to use the memcache for my other board as well in due course.
    Code:
    106      18722  0.5  0.8  57952 31272 ?        Ssl  May18  13:40 /usr/bin/memcached -d -p 11211 -l 127.0.0.1 -m 512 -c 1024 -u memcached -P /var/run/memcached/memcached-11211.pid
    The only thing that changed was this section:
    Code:
    	// ****** DATASTORE CACHE CONFIGURATION ***** 	// Here you can configure different methods for caching datastore items. 	// vB_Datastore_Filecache  - to use includes/datastore/datastore_cache.php 	// vB_Datastore_APC - to use APC 	// vB_Datastore_XCache - to use XCache 	// vB_Datastore_Memcached - to use a Memcache server, more configuration below // $config['Datastore']['class'] = 'vB_Datastore_Filecache';  	// ******** DATASTORE PREFIX ****** 	// If you are using a PHP Caching system (APC, XCache, eAccelerator) with more 	// than one set of forums installed on your host, you *may* need to use a prefix 	// so that they do not try to use the same variable within the cache. 	// This works in a similar manner to the database table prefix. // $config['Datastore']['prefix'] = '';  	// It is also necessary to specify the hostname or IP address and the port the server is listening on /* $config['Datastore']['class'] = 'vB_Datastore_Memcached'; $i = 0; // First Server $i++; $config['Misc']['memcacheserver'][$i]		= '127.0.0.1'; $config['Misc']['memcacheport'][$i]			= 11211; $config['Misc']['memcachepersistent'][$i]	= true; $config['Misc']['memcacheweight'][$i]		= 1; $config['Misc']['memcachetimeout'][$i]		= 1; $config['Misc']['memcacheretry_interval'][$i] = 15; */
    to this:
    Code:
     	// ****** DATASTORE CACHE CONFIGURATION ***** 	// Here you can configure different methods for caching datastore items. 	// vB_Datastore_Filecache  - to use includes/datastore/datastore_cache.php 	// vB_Datastore_APC - to use APC 	// vB_Datastore_XCache - to use XCache 	// vB_Datastore_Memcached - to use a Memcache server, more configuration below 	// $config['Datastore']['class'] = 'vB_Datastore_Filecache';  	// ******** DATASTORE PREFIX ****** 	// If you are using a PHP Caching system (APC, XCache, eAccelerator) with more 	// than one set of forums installed on your host, you *may* need to use a prefix 	// so that they do not try to use the same variable within the cache. 	// This works in a similar manner to the database table prefix. $config['Datastore']['prefix'] = 'heli';  	// It is also necessary to specify the hostname or IP address and the port the server is listening on  $config['Datastore']['class'] = 'vB_Datastore_Memcached'; $i = 0; // First Server $i++; $config['Misc']['memcacheserver'][$i]		= '127.0.0.1'; $config['Misc']['memcacheport'][$i]			= 11211; $config['Misc']['memcachepersistent'][$i]	= true; $config['Misc']['memcacheweight'][$i]		= 1; $config['Misc']['memcachetimeout'][$i]		= 1; $config['Misc']['memcacheretry_interval'][$i] = 15;
    I'm going to play with the setup now but thought I'd post where I was at since I initially looked at the plugins and what not but found it to be something to do with memcache setup...

    Leave a comment:


  • Jake Bunce
    replied
    Try disabling products, not plugins:

    Admin CP -> Plugins & Products -> Product Manager -> Disable (in each product menu)

    Leave a comment:


  • wtrk
    replied
    so i went through and disabled each plugin individually and tried to edit a post after disabling each one, and by disabling one at a time i was unable to find a single plugin that was responsible because it still didnt work when i disable each one individually but when i turn off the entire hooks system it works like normal.

    so.. does this mean that is a combonation of plugins thats causing the problem or is it custom code somewhere else that might be causing it?

    Leave a comment:


  • wtrk
    replied
    turned off plugins/hooks and then edited a thread without a problem. so it must be a plugin thats causing the problem?

    Leave a comment:


  • Jake Bunce
    replied
    I have no idea what that is. I suspect there is a customization that is causing this. You can quickly determine this by temporarily disabling your customizations. Try to reproduce it on a default style:

    Admin CP -> Styles & Templates -> Style Manager -> [Add New Style]

    Create a new style with no parent. Then click that style's name in the Style Manager to view your forum with that style. If the problem goes away on the default style then you know it's a style problem at which point you need to systematically revert your custom templates to isolate the problem.

    If you still have the problem then try disabling your plugins:

    Admin CP -> vBulletin Options -> Plugin/Hook System

    Also run a file check to look for customized files. Upload the original files if any problems are reported:

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    Leave a comment:


  • wtrk
    started a topic maxloggedin error on edit post

    maxloggedin error on edit post

    hey all,

    i just upgraded from php 4.something to php 5.latest and everything seems to be all good except for one thing, when you edit a post and hit save you get a popup window that says:

    vbulletin message

    1. maxloggedin

    cancel changes
    can somebody help me fix this please?

    thanks!

    edit: see attached image
    Attached Files
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X