Announcement

Collapse
No announcement yet.

Stuck on step 2 (different to Peoplecore though)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Stuck on step 2 (different to Peoplecore though)

    Hey all

    Iv read people cores post, but I have a different message.

    It isnt exactly an error, but its saying this:

    Step 2) Connect to the database
    Selected database type 'mysqli' was not detected within your compilation of PHP.

    What do I do to fix this problem

    Any help for a noob..?

    Thanks

    Howie.

  • #2
    Originally posted by Howie66 View Post
    Step 2) Connect to the database
    Selected database type 'mysqli' was not detected within your compilation of PHP.
    Isn't that 'mysqli' "mysql"?
    Seems wrong database type.


    vB5 is unequivocally the best forum software, but not yet...

    Comment


    • #3
      Originally posted by beishe8 View Post
      Isn't that 'mysqli' "mysql"?
      Seems wrong database type.
      Yep, now ive got the same error as the other thread..

      The database has failed to connect because you do not have permission to connect to the server. Please confirm the values entered in the 'includes/config.php' file.

      Ok lets say my db name is "Howie".. what else should i put, like any "_" or db? or _slave?

      Help me people!

      Howie.

      Comment


      • #4
        Originally posted by Howie66 View Post
        Ok lets say my db name is "Howie".. what else should i put, like any "_" or db? or _slave?
        Another example:
        Database name: myforum
        User name: Howie

        then with certain webhosts the database name could become: Howie_myforum


        vB5 is unequivocally the best forum software, but not yet...

        Comment


        • #5
          OK cool.. done

          NOW.. another error

          Error description: mysql_connect(): Can't connect to local MySQL server through socket *leftblank*mysql-5.0/data/mysql.sock' (2) *left blank*Forum/includes/class_core.php on line 311
          Last edited by Howie66; Mon 5 Jan '09, 2:23am.

          Comment


          • #6
            Assuming the db info in your config.php file is correct, this is a server issue. Please see this page for the causes of this error:

            http://www.vbulletin.com/docs/html/cantconnect
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              your database user / name is usually

              cpanelusername_namegiven (assuming you're using shared hosting) e.g if your username is bob it would be bob_forum

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X