Announcement

Collapse
No announcement yet.

Duplicate posts

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Duplicate posts

    I've been running into some issues lately- occasionally, when attempting to make a post on my board, it'll spend twice as long loading and spit out two identical posts- this has happened a number of times and oddly seems to affect my staff the most. It happens regardless of whether a reply is submitted using Quick Reply or through clicking "Post Reply", but it does not happen with every single post.

    I am currently running vBulletin 3.7.2- I can upgrade any time if it would solve the problem.

  • #2
    1) I have seen double posting problems caused by not having a flood check:

    Admin CP -> vBulletin Options -> Message Posting and Editing Options -> Minimum Time Between Posts

    Make sure this is not set to 0.

    2) You might also try disabling the problematic AJAX features (which includes the quick reply):

    Admin CP -> vBulletin Options -> General Settings -> Disable AJAX Features

    3) Email notifications can also cause delays when posting if the mail server is being slow. Try disabling email features to test this:

    Admin CP -> vBulletin Options -> Email Options -> Enable Email features?

    Comment


    • #3
      Hi Jake,

      I've got a flood check of 30 seconds at the time being.

      I do have all AJAX features enabled at the time being, I will set it to disable problematic features for the time being to see if it affects anything.

      My e-mail features are turned on- although I will hold off making any changes to that until I can see if the AJAX features are the cause.

      Thanks!

      Comment


      • #4
        I've started to get similar issues with 3.8 RC2. Mainly affects staff on post reply. Quick reply seems OK

        Comment


        • #5
          It mainly affects staff on my site as well- although Quick Reply is more often affected.

          Anyway, disabling problematic AJAX didn't solve the problem, so I am disabling email features. Should that fail to fix it I will move on to disable all AJAX and see where that takes me.

          Comment


          • #6
            Admins and mods are exempt from the flood check. That may have something to do with it.

            Comment


            • #7
              That makes sense then- I don't recall ever seeing a double post by non-staff.

              So, next question should be obvious. How do I fix it?

              Comment


              • #8
                Unfortunately I am out of ideas. I have listed all possible explanations that I can think of based on my experience with this problem.

                Comment


                • #9
                  Apoligies for bringing back a semi old post but seemed better than making a new thread.
                  I am having the same issues also with double posts and is only happening with Admins.

                  Is the only options available for a solution to disable ajax and then possibly the email replys too? Is there no other fix available?

                  Comment


                  • #10
                    AJAX is the most probable cause. When your connection is laggy or unreliable then AJAX posting can result in double posts.

                    Comment


                    • #11
                      I have the same problem since the update to 3.7.5. But the problem only occurs with the Firefox browser.

                      Everything works fine with Opera.

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X