Announcement

Collapse
No announcement yet.

Problem with Font Color Option after Upgrade

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with Font Color Option after Upgrade

    Hi, after we did our recent upgrade to the 3.7.4 Patch Level 1 we have something wrong with our font color option when posting a message. Any ideas? Thanks.

  • #2
    What do you mean?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Terrib:

      Try this thread, it might be the same issue I was having...http://www.vbulletin.com/forum/showthread.php?t=293834

      Comment


      • #4
        Thanks so much Palmer5555, but that's not exactly the problem we're having so it didn't resolve it.

        When posting a message & you wish to change the font color using the pop down menu, there are no other font color choices. You only have the option to use black as the font color. Before upgrading we had many font color options to choose from.

        Any ideas? Thanks!

        Comment


        • #5
          Make sure all the WYSIWYG editors are enabled here:

          Admin CP -> vBulletin Options -> Message Posting Interface Options -> Enable Clickable Message Formatting Controls

          Then make sure you have selected the enhanced editor in your User CP:

          User CP -> Edit Options -> Message Editor Interface -> Enhanced Interface


          This should work assuming you have not altered the templates.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            Thank you so much Steve, but here's the dumb question - where do I find the User CP???

            Thanks again for your help!

            Comment


            • #7
              Nevermind that last question about the User CP - I figured that out.

              But, I did everything you said to do & I still get no font color options. I haven't touched any of the templates, so I'm a bit baffled.

              Thanks for any help!

              Comment


              • #8
                Then it has to be from a modification.

                To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

                Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

                [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

                Next, disable all plugins.

                Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

                define('DISABLE_HOOKS', true);

                Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

                Do you have the same problem?
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Thanks so much for your reply Steve, but I don't understand what I'm supposed to do here.

                  Am I supposed to shut the forums down & re-upload all the old files I saved in the back up I performed before installing the upgrade?? And then I'll have to start all over with the upgrade again??

                  I'm sorry I'm so confused & so dense.

                  Comment


                  • #10
                    To simplify this, try the last paragraph first. It could just be a style issue.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      Thanks so much Steve. That worked. So, now what do I do to fix it?? I'd like to be able to use the default style & not this 'bare' style.

                      Again, thanks so much!

                      Comment


                      • #12
                        Yes, that means that your custom style is at fault, most likely the newthread and/or newreply templates. You may have to revert those.
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment


                        • #13
                          Need help desperately.

                          Hey Steve, Howe are you and Happy Holidays to you and yours.

                          After having a forum up for almost 3 years... i figured I would upgrade this weekend.

                          Im having a similar issue... the entire editing options do not work when creating a new message or replying to one with the full editor... but it works with the quick reply editor.

                          I checked the Message Posting Options... Checked my UserCP settings... Disabled all the hooks and swiched back and forth between all templates... and still none of the editing works on these messages. Not even adding smilies.

                          I even tried changing the settings to use the basic Editing settings like the Quik reply... still none of these work.

                          I then re-uploaded all the .php pages in the root directory...

                          Still a no go.


                          Do you have any idea what it may be?

                          Any help would be greatly appreciated.

                          www.myholidaydisplays.com

                          Comment


                          • #14
                            This does work with the default vB code and templates and no add-ons. Follow all the instructions in post #8. Then if you still have this problem with the default vB, please start your own thread.
                            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                            Change CKEditor Colors to Match Style (for 4.1.4 and above)

                            Steve Machol Photography


                            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                            Comment


                            • #15
                              Thank you Steve, I will double check everything again!

                              Happy holidays!!

                              Tim

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X