Announcement

Collapse
No announcement yet.

Linking a image to a url

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Linking a image to a url

    I'm trying to insert a link on a picture so when users click the image located in a post, they are re-directed to a webpage on my site. But at the moment when they click the image, the image pops up. How do I get he 'insert url' to stick to my image?

    The only solution I've come up with is turning on html in posts for administrators. Using code like this:

    <a href="../forum.php><img src="../mypictures.jpg alt="Pictures" /></a>

    It works unless I edit the post. If I edit the post, the code get's re-written and no longer links to the image.

    Can someone please help

  • #2
    Use this BBCode instead of HTML:

    [url=http://yoururl.com][img]http://path/to/image[/img][/url]

    example (click to come back to this thread):

    Comment


    • #3
      Originally posted by TriMe View Post
      The only solution I've come up with is turning on html in posts for administrators.
      I don't think that it is possible to turn on HTML for administrators ONLY.
      Take care with it.


      vB5 is unequivocally the best forum software, but not yet...

      Comment


      • #4
        Originally posted by RomeoCharlie View Post
        Use this BBCode instead of HTML:

        [url=http://yoururl.com][img]http://path/to/image[/img][/url]

        example (click to come back to this thread):
        Thats the code I use. But after I save the link URL link doesn't work, so I edit it and the code looks like this:

        [url=http://path.to.image.com][/url][url=http://yoururl.com][img]http://path/to/image[/img][/url]

        Everytime I save a post.. it adds a [url=http://path.to.image.com][/url] to the front of the original.

        I'm lost!

        Comment


        • #5
          Originally posted by TriMe View Post
          I'm lost!
          Try it one more time:

          Your image is: h ttp://mysite.com/images/testimage.jpg

          Click on Insert Image

          "Please enter the URL of your image:"
          Type in the URL which is h ttp://mysite.com/images/testimage.jpg

          Click on OK

          Should become like this:
          [IMG]h ttp://mysite.com/images/testimage.jpg[/IMG]

          Highlight that whole line
          Click on "Insert URL"

          "Please enter the URL of your link:"
          Type in the URL which is: h ttp://mysite.com
          Click on OK

          Should become like this:
          [URL ="http://mysite.com"][IMG]h ttp://mysite.com/images/testimage.jpg[/IMG][/url]

          (Delete the spaces from my example)
          Last edited by beishe8; Fri 12 Dec '08, 3:01pm.


          vB5 is unequivocally the best forum software, but not yet...

          Comment


          • #6
            "Please enter the URL of your image:"
            Type in the URL which is h ttp://mysite.com/images/testimage.jpg

            Click on OK

            Should become like this:
            [IMG]h ttp://mysite.com/images/testimage.jpg[/IMG]

            Highlight that whole line
            Click on "Insert URL"
            Maybe the problem is, the code doesn't come up. A thumbnail does. Is there a way to disable that?
            Attached Files

            Comment


            • #7
              Originally posted by TriMe View Post
              Maybe the problem is, the code doesn't come up. A thumbnail does. Is there a way to disable that?
              I don't know that what is that "F" for? From some modification?(such as youtube)
              Perhaps that modification is stirring trouble?


              vB5 is unequivocally the best forum software, but not yet...

              Comment


              • #8
                This mod was giving me the headache. Thanks for your help

                Comment

                Related Topics

                Collapse

                Working...
                X