Announcement

Collapse
No announcement yet.

Trying to center my forum header logo

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Trying to center my forum header logo

    I searched and found lots of useful info on how to make fluid images and the like, but nothing on how to simply center the forum header image.

    Hope someone can help - thanks!

  • #2
    you can center anything with <center>imagecodehere</center> or <div align="center">whateveryouwantcenteredhere</div>

    Comment


    • #3
      Originally posted by Blanky View Post
      you can center anything with <center>imagecodehere</center> or <div align="center">whateveryouwantcenteredhere</div>
      Thanks! Had to toy around about with the header code but thanks to what you posted it's golden now.

      Comment


      • #4
        Originally posted by Blanky View Post
        you can center anything with <center>imagecodehere</center> or <div align="center">whateveryouwantcenteredhere</div>
        I'm trying to center it as well and I don't really understand what you mean by the above. Would anybody be so kind to guide me through it step by step...

        The logo I wish to have centered is in my brand new board:

        http://www.captainsvoyage-forum.com

        Thank you to the one who will help me with this and Merry Christmas!

        Comment


        • #5
          Originally posted by pakarang View Post
          I'm trying to center it as well and I don't really understand what you mean by the above. Would anybody be so kind to guide me through it step by step...

          The logo I wish to have centered is in my brand new board:

          http://www.captainsvoyage-forum.com

          Thank you to the one who will help me with this and Merry Christmas!
          Hi,
          I think I know an easy fix for this.
          Follow this path:
          Admin Panel > Styles and Templates > Style Manager > Edit Template > Header
          Find this code:
          <!-- logo -->
          <a name="top"></a>
          <table border="0" width="$stylevar[outertablewidth]" cellpadding="0" cellspacing="0" align="center">
          <tr>
          <td align="left"><a href="$vboptions[forumhome].php$session[sessionurl_q]"><img src="$stylevar[titleimage]" border="0" alt="$vboptions[bbtitle]" /></a></td>

          </tr>
          </table>
          <!-- /logo -->
          Change the 'left' shown in bold to 'center' and then click 'Save and Reload'.
          Check your forum to make sure it looks right and then close the Admin panel!

          This worked to center my logo.

          Comment


          • #6
            Thank you so much for the very understandable and easy solution: it didn't however seem to work with my board.... the logo still seems to be a bit off to the left.

            Comment


            • #7
              Originally posted by Kestryll View Post
              Hi,
              I think I know an easy fix for this.
              Follow this path:
              Admin Panel > Styles and Templates > Style Manager > Edit Template > Header
              Find this code:
              Change the 'left' shown in bold to 'center' and then click 'Save and Reload'.
              Check your forum to make sure it looks right and then close the Admin panel!

              This worked to center my logo.
              I tried this and it stays on the left

              www.nflextremefans.com

              Comment


              • #8
                In order to center the logo, you need to edit the Header Template:

                AdminCP > Styles & Templates > Style Manager > Common Templates (from drop menu next to style name)

                The first portion of the Header Template is what you need to edit.

                Find this:

                <!-- logo -->
                <a name="top"></a>
                <table border="0" width="$stylevar[outertablewidth]" cellpadding="0" cellspacing="0" align="center">
                <tr>
                <td align="$stylevar[left]"><a href="$vboptions[forumhome].php?$session[sessionurl]"><img src="$stylevar[titleimage]" border="0" alt="$vboptions[bbtitle]" /></a></td>
                <td align="$stylevar[right]">
                &nbsp;
                <!--
                NEW HEADER &amp; NAVBAR

                Now that the nav buttons are in the
                navbar template, you can stick whatever
                you like into this space.

                This makes it much easier for novice
                admins to customize their header
                template without affecting important
                navigation elements.
                -->
                </td>
                </tr>
                </table>
                <!-- /logo -->


                And replace it with this:

                <!-- logo -->
                <a name="top"></a>
                <table border="0" width="$stylevar[outertablewidth]" cellpadding="0" cellspacing="0" align="center">
                <tr>
                <td align="$stylevar[left]"><a href="$vboptions[forumhome].php?$session[sessionurl]"><center><img src="$stylevar[titleimage]" border="0" alt="$vboptions[bbtitle]" /></center></a></td>
                </tr>
                </table>
                <!-- /logo -->
                Translations provided by Google.

                Wayne Luke
                The Rabid Badger - a vBulletin Cloud demonstration site.
                vBulletin 5 API

                Comment


                • #9
                  Thank you very much mR. Luke... It worked and I'm so happy. Thank you once again and Merry Christmas!

                  Comment


                  • #10
                    On 3.74 I have the following additional html:

                    <td align="$stylevar[right]" id="header_right_cell">
                    <if condition="$ad_location['ad_header_logo']">$ad_location[ad_header_logo]<else />&nbsp;</if>
                    </td>

                    Does this get replaced as well?

                    Thank you

                    Comment


                    • #11
                      Originally posted by captkirk685 View Post
                      I tried this and it stays on the left

                      www.nflextremefans.com
                      got it to work, thanks..

                      Comment


                      • #12
                        Originally posted by pakarang View Post
                        Thank you very much mR. Luke... It worked and I'm so happy. Thank you once again and Merry Christmas!
                        Umm... so sorry to be such a pain but three members are complaining they get my forum like this after doing the above (I must say that with me, it all looks perfect though): what may I have messed up now (probably my codes)?



                        Comment

                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                        Working...
                        X