Announcement

Collapse
No announcement yet.

Is there a Smilies cache?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Is there a Smilies cache?

    I just completed a merge using ImpEx a days ago. I'm pretty sure I set the ImpEx NOT to over-write my target board smilies, but it did. (Maybe I didn't, but nevermind)

    Last night, I fixed it by going into the smilies table in the DB to change the paths back to the original ones. Now the smilies appear correctly in the WYSIWYG editor smilie panel, and also in the text box. But once the post is submitted, vBulletin replaces the smiley codes with the old (and wrong) path to the smiley.

    If I Quick-Edit the post, it shows the correct one again. Re-submit, and it displays the wrong one.

    I've tried rebuilding the post cache, but there is no effect.

    Help? Thanks.
    Vincent
    Running vBulletin for AquaticQuotient.com - a community of aquarium lovers

  • #2
    I'm not sure how rebuilding the post cache and emptying the postparsed table is. But you could try to empty the postparsed table. Also try using a program like CCleaner to completely remove any cache on you computer. Or you can try another computer to make sure it's not a cache issue on the browser side.

    Comment


    • #3
      It occurred to me a short while ago that if I did it the proper way... i.e. edit the smilies through the Admin CP, vB would fix things for me. So I did... and now it's fine.

      I went into the database tables because it was less tedious.

      It's not the browser cache. The smiley image paths were significantly different... and some of the posts I opened for the first time or I just posted.

      I suspect the smileys are cached in the datastore table.
      Vincent
      Running vBulletin for AquaticQuotient.com - a community of aquarium lovers

      Comment


      • #4
        I found that when I uploaded smileys through the admincp (rather than creating entries pointing to smilies already on disk) they'd show up in the preview/quick reply AJAX, but if you were hitting the thread from anywhere else you would just see the replacement text.

        Manually re-saving the smilies (cp -> edit smilies -> one by one) and then truncating postparsed/sigparsed fixed it. I think it worked in the preview/AJAX quick reply because those don't go through postparsed.

        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X