Announcement

Collapse
No announcement yet.

Fatal error while guest trying to register!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Fatal error while guest trying to register!


    Code:
    [COLOR=#000000][FONT=times new roman][B]Fatal error[/B]: Call to a member function clean_gpc() on a non-object in [B]/home/xx/public_html/forums/includes/class_dm_user.php(2900) : eval()'d code[/B] on line [B]1[/B][/FONT][/COLOR]
    While any guest is trying to register, Its ok untill the final step at
    http://xxx.com/forums/register.php?do=addmember, they are getting this msg.

    They can be member, and default welcome msg also okay.. but there is no new name at the bottom forum index "Welcome to our newest..."

    How can I get rid of it guys? Thanks in advance.

  • #2
    Try disabling your plugins and see if you still have this problem.
    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

    PHP Code:
    define('DISABLE_HOOKS'true); 

    Please don't PM or VM me for support - I only help out in the threads.
    vBulletin Manual & vBulletin 4.0 Code Documentation (API)
    Want help modifying your vbulletin forum? Head on over to vbulletin.org
    If I post CSS and you don't know where it goes, throw it into the additional.css template.

    W3Schools &lt;- awesome site for html/css help

    Comment


    • #3
      Lynne, it works fine. So, it means.. any hack that I put is causing the problem.. right?

      Comment


      • #4
        There is a addon that is trying to add or modify data in the register process, you can check the list of plugins and see which are using register hooks.

        Comment


        • #5
          All I can do disabling one after another addon to get the problem maker. painful. Any best way to check wich one is using register hook?

          Thanks for replying Z.

          Comment


          • #6
            Check your plugins, see which ones use register_

            Comment


            • #7
              Zach, now thats interesting. I found none!

              http://img126.imageshack.us/my.php?i...4547086ls3.jpg
              Attached Files

              Comment


              • #8
                Can't see a thing on your list since it got shrunk. Sometimes they don't show up in the actual register_ hook, but it another associated with registering. Just disable all products, then turn them on one by one until registration breaks.

                Please don't PM or VM me for support - I only help out in the threads.
                vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                Want help modifying your vbulletin forum? Head on over to vbulletin.org
                If I post CSS and you don't know where it goes, throw it into the additional.css template.

                W3Schools &lt;- awesome site for html/css help

                Comment


                • #9
                  Did you check my imageshack link? Any way.. I am doing the way that u said now.

                  Comment


                  • #10
                    Originally posted by aupurbo View Post
                    Did you check my imageshack link? Any way.. I am doing the way that u said now.
                    Yes, I did. But take a look at it - it's was resized to be too small to read.

                    Please don't PM or VM me for support - I only help out in the threads.
                    vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                    Want help modifying your vbulletin forum? Head on over to vbulletin.org
                    If I post CSS and you don't know where it goes, throw it into the additional.css template.

                    W3Schools &lt;- awesome site for html/css help

                    Comment


                    • #11
                      Lynne.. I got the culprit. http://www.vbulletin.org/forum/showthread.php?t=196026

                      thats the one. I disble it and all going well. I dont see anybody got same issue with that hack. Its strange, I am contacting with Rob.

                      Or if u get any solution for it?

                      Comment


                      • #12
                        Glad you found the culprit!

                        I don't use that modification, so I don't know what the cause could be.

                        Please don't PM or VM me for support - I only help out in the threads.
                        vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                        Want help modifying your vbulletin forum? Head on over to vbulletin.org
                        If I post CSS and you don't know where it goes, throw it into the additional.css template.

                        W3Schools &lt;- awesome site for html/css help

                        Comment


                        • #13
                          Thanks, Zach and Lyn.. both of u.

                          Comment

                          Related Topics

                          Collapse

                          Working...
                          X