Announcement

Collapse
No announcement yet.

Server Upgrade screwed up my site - Suhosin?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Server Upgrade screwed up my site - Suhosin?

    My Host has been upgrading their servers today which has created havoc on my site, and I'm getting the folllowing error when I try to change my style in the admincp:

    Required variables have gone missing and execution can not continue. Please try again.

    This error can sometimes occur as a result of Suhosin / Hardened PHP being installed on your server. If you know that you have Suhosin running and you have access to the PHP configuration, try increasing the value of the following variables:
    • php_value suhosin.post.max_vars
    • php_value suhosin.request.max_vars
    I contacted them and they said that the Suhosin is at 200.

    I don't know anything about this or what it means, but it definitely seems that they have done a number on my site by making changes on their end. The really annoying thing is that my site is down a lot because of this host too. I'd love to know what a good host is.

    Please advise, provide help

    I was also getting a database error:

    MySQL Error : Got error 28 from storage engine
    Error Number : 1030
    Last edited by Eternal_; Tue 25 Nov '08, 12:09pm.

  • #2
    1. The most likely cause of this problem is the suhosin module in PHP. If so this can be fixed by editing the php.ini (requires root access to the server) or by via a .htaccess file with the following contents:

    php_flag suhosin.cookie.encrypt Off
    php_value suhosin.request.max_vars 2048
    php_value suhosin.post.max_vars 2048


    You can create your own .htaccess file and upload it to your main forum directory. It's a simple text file.

    If this doesn't work or you get an 'Internal Server Error' after doing this, then unfortunately this means that your host is not allowing this change. The only thing you can do now is to ask your host to make the necessary changes to suhosin.

    Here is a post that lists some of the recommended suhosin settings for compatibility with vB:

    http://www.vbulletin.com/forum/showt...82#post1329782

    2. That error means:

    Error code 28: No space left on device

    One or more partitions on your server is out of space or doesn't have enough space to complete this operation. Shutdown your forums (if you can) and contact your host immediately. You or your host will need to find out which partition is low on space and free up some more space.

    Here is an explanation of the error on the MySQL site:

    http://www.mysql.com/news-and-events...000000249.html
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      I tried the .htaccess but it didnt work.

      Where I'm having problems is in the styles & templates > style manager section where I change the css attributes . It gives me the error listed above in quotes.

      The host said they have suhosin set to 200. (What kind of an upgrade is that? They do upgrades that cause my site to not be compatible )

      Are there any recommended hosting providers out there that are more reliable and efficient? I seem to have problems regularly with my host.

      Comment


      • #4
        Then this means your host is blocking those changes. You need to read the rest of my post and contact them.

        And you will have this problem unless they change those settings.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          I got it working.

          Here's what I did (I'm not sure if they did something else as well, but after I did this is started to work again).

          They created a php.ini page but they had this

          php_value suhosin.request.max_vars 2048
          php_value suhosin.post.max_vars 2048
          php_flag suhosin.cookie.encrypt on

          so I changed it to what you said

          php_flag suhosin.cookie.encrypt Off
          php_value suhosin.request.max_vars 2048
          php_value suhosin.post.max_vars 2048

          and this seemed to fix it.

          Thank you very much for your support. It is always quite stressful when something happens and is out of my control. When working for thousands of hours on a site, it's horribly worrying that it could be royally messed. Now I feel relieved. I just hope these kinds of issues don't randomly continue.

          Comment


          • #6
            I am however now getting the following error (Is this common?)

            Forbidden

            You don't have permission to access / on this server.
            Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
            Apache/2.2.10 (Unix) mod_ssl/2.2.10 OpenSSL/0.9.7a mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at www.esotericforum.com Port 80

            Comment


            • #7
              This may be due to mod_security. Please see this thread for the fix:

              http://www.vbulletin.com/go/modsecurity
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X