Announcement

Collapse
No announcement yet.

Problem with register in forum

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with register in forum

    hi

    I have a problem with register in my forum vb .
    after register the page show 2 error .
    Code:
    Unable to add cookies, header already sent.
    File: /home/*****/public_html/forum/includes/class_dm_user.php(2852) : eval()'d code
    Line: 8
    and in header :
    Code:
    Parse error: syntax error, unexpected T_ENCAPSED_AND_WHITESPACE, expecting ']' in /home/******/public_html/forum/includes/class_dm_user.php(2852) : eval()'d code on line 8
    I run this instruct but I still have that problem !
    Code:
                              This error is from a plugin you've installed. I don't see how you can get that error with plugins disabled.
    
    To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents': 
    
    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions 
    
    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]
    
    Next, disable all plugins.
    
    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php
    
    define('DISABLE_HOOKS', true);
    
    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Do you have the same problem?
    I reupload all files (upgrade to 3.7.4) and disable all Plugin and add '' define('DISABLE_HOOKS', true);'' to config.php .
    when i run ''Suspect File Versions'' the page show this message :
    Code:
    ./vbseo_sitemap
    extra-urls.txt      File not recognized as part of vBulletin
    index.php     File does not contain expected contents
    vbseo_getsitemap.php     File does not contain expected contents
    vbseo_sitemap.php     File does not contain expected contents
    vbseo_sitemap_config.php     File does not contain expected contents
    vbseo_sitemap_functions.php     File does not contain expected contents
    vbseo_sm_config30x.php     File does not contain expected contents
    
    
    ./vbseo_sitemap/addons
    vbseo_sm_downloads.php     File does not contain expected contents
    vbseo_sm_downloads2.php     File does not contain expected contents
    vbseo_sm_vba.php     File does not contain expected contents
    vbseo_sm_vba_links.php     File does not contain expected contents
    please help me
    thanks

  • #2
    The error is being caused by your addons, you can try disabling them one by one and seeing which one is causing the error.

    Comment


    • #3
      hi

      I disable all installed Product in my forum one by one , but that problem not fixed!!!
      when disable a Product = clear cache & close firefox and open again .
      what can I do to fix this problem ?

      sorry fo my bad english!

      thanks

      Comment


      • #4
        please help

        my forum :
        http://all4persian.com

        Comment


        • #5
          If you are getting the same error, then this is still caused by an add-on.

          To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

          Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

          [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

          Next, disable all plugins.

          Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

          define('DISABLE_HOOKS', true);


          Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

          Do you have the same problem?
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            I run all you say
            but I still have this problem !!!

            Comment


            • #7
              If you are getting the same error, then this is still caused by an add-on. It is not possible to get that error if you followed all of those instructions.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                I disable send welcom message (with Private Messages) after register and my problem was gone .
                thank you for your help .
                Last edited by mohammad_62; Wed 12 Nov '08, 9:44am.

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X